ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-687

LENonterminatetest fails on some machines.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      LENonterminateTest fails with the following error:

      2010-03-04 20:26:32,347 - INFO  [Thread-0:LeaderElection@155] - Server address: 0.0.0.0/0.0.0.0:11223
      2010-03-04 20:26:32,348 - WARN  [Thread-0:LeaderElection@195] - Ignoring exception while looking for leader
      java.io.IOException: Network is unreachable
      	at java.net.PlainDatagramSocketImpl.send(Native Method)
      	at java.net.DatagramSocket.send(DatagramSocket.java:612)
      	at org.apache.zookeeper.server.quorum.LeaderElection.lookForLeader(LeaderElection.java:169)
      	at org.apache.zookeeper.test.LENonTerminateTest$LEThread.run(LENonTerminateTest.java:83)
      
      1. ZOOKEEPER-687.patch
        14 kB
        Mahadev konar
      2. ZOOKEEPER-687.patch
        0.9 kB
        Mahadev konar

        Activity

        Hudson added a comment -

        Integrated in ZooKeeper-trunk #715 (See http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/715/)
        . LENonterminatetest fails on some machines. (mahadev)

        Mahadev konar added a comment -

        I just committed this.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12437936/ZOOKEEPER-687.patch
        against trunk revision 919149.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/127/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/127/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/127/console

        This message is automatically generated.

        Patrick Hunt added a comment -

        +1 looks good to me.

        Mahadev konar added a comment -

        used 127.0.0.1 instead of localhost. thanks pat for the suggestion. Also replaced other occurences of localhost with 127.0.0.1.

        Mahadev konar added a comment -

        I ran the tests on hudson machines with the patch and it passes. So we can go ahead and commit (of course after having reviewed) if we want without waiting for hudson.

        Mahadev konar added a comment -

        this patch fixes the issue in test and changes it to use localhost rather than 0.0.0.0.

        Mahadev konar added a comment -

        the issue is that the leaderelection test uses 0.0.0.0 as the default ipaddress for binding and sending. I will change the test to use one of the ip addresses (localhost) so that there is no issue in sending UDP packets with 0.0.0.0 ipv4 header.


          People

          • Assignee:
            Mahadev konar
            Reporter:
            Mahadev konar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development