ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-570

AsyncHammerTest is broken, callbacks need to validate rc parameter

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.3.0
    • Component/s: tests
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      the asynchammertest is not validating the rc in the callback, more serious is that it is using path in the create callback
      to delete the node, rather than name (which is important in the case of a sequential node creation as in this case)

      1. ZOOKEEPER-570.patch
        6 kB
        Patrick Hunt
      2. ZOOKEEPER-570.patch
        5 kB
        Patrick Hunt

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Patch Available Patch Available Open Open
        14h 23m 1 Patrick Hunt 08/Nov/09 21:47
        Open Open Patch Available Patch Available
        49m 28s 2 Patrick Hunt 08/Nov/09 21:50
        Patch Available Patch Available Resolved Resolved
        56m 1 Benjamin Reed 08/Nov/09 22:46
        Resolved Resolved Closed Closed
        137d 18h 38m 1 Patrick Hunt 26/Mar/10 17:25
        Patrick Hunt made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in ZooKeeper-trunk #545 (See http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/545/)
        . AsyncHammerTest is broken, callbacks need to validate rc parameter

        Patrick Hunt made changes -
        Fix Version/s 3.2.2 [ 12314335 ]
        Patrick Hunt added a comment -

        Dropping this from 3.2.2, it's not a bug fix (well, it is a fix to a test) but it does depend on refactored code from
        3.3, it's not clear how this would be done (easily/successfully), dropping from 3.2.2

        Hudson added a comment -

        Integrated in ZooKeeper-trunk #528 (See http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/528/)

        Benjamin Reed made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Benjamin Reed added a comment -

        Committed revision 833938.

        Benjamin Reed made changes -
        Hadoop Flags [Reviewed]
        Benjamin Reed added a comment -

        +1 good job. what a messed up patch!

        Patrick Hunt made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Patrick Hunt made changes -
        Attachment ZOOKEEPER-570.patch [ 12424325 ]
        Patrick Hunt added a comment -

        same patch as before, however I noticed that there was a serious flaw with the
        verification phase, which restarted the quorum. The restart code was wrong,
        it caused a new quorum to be started, rather than restarting the existing quorum.

        This addresses the original cause of the test failing, plus the original patch's
        fix for the delete not being correct (etc...)

        Patrick Hunt made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12424290/ZOOKEEPER-570.patch
        against trunk revision 833639.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 5 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/55/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/55/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Zookeeper-Patch-h8.grid.sp2.yahoo.net/55/console

        This message is automatically generated.

        Patrick Hunt made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Patrick Hunt made changes -
        Field Original Value New Value
        Attachment ZOOKEEPER-570.patch [ 12424290 ]
        Patrick Hunt added a comment -

        Fixed the test:

        1) delete now uses name rather than path (since create is using seq flag)
        this was the main issue previously
        2) fail the test if create or delete operations fail
        3) don't send messages to the server until connected - otw false positive failure due to queued aysnc op when client times out

        Patrick Hunt created issue -

          People

          • Assignee:
            Patrick Hunt
            Reporter:
            Patrick Hunt
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development