• Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: server
    • Labels:


      In some cases there is no need to have the ZK data persisted to disk. For example if all you are doing is group membership and leadership
      election the data is totally ephemeral, storing on disk is unnecessary. We've also seen cases where any non-ephemeral data can be
      easily recovered (say configuration data that's generated/read and loaded into zk) and there is less need to worry about recovery of the
      data in the case of catastrophic failure (meaning all replicas are lost, remember, recovery is automatic if 2n+1 servers and <= n servers
      fail, even if > n fail manual recovery is still possible as long as at least 1 replica, or replica backup can be recovered)

      In these cases it makes sense to have a "diskless" zookeeper ensemble. The result should be improved write performance
      an less moving parts (no disk to fail!), simplifiying ops in cases where this can be applied.


        Patrick Hunt created issue -
        Patrick Hunt made changes -
        Field Original Value New Value
        Fix Version/s 3.4.0 [ 12314469 ]
        Fix Version/s 3.3.0 [ 12313976 ]
        Andrei Savu added a comment -

        Closing as a duplicate of ZOOKEEPER-866 (already has a patch attached).

        Andrei Savu added a comment - Closing as a duplicate of ZOOKEEPER-866 (already has a patch attached).
        Andrei Savu made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Patrick Hunt made changes -
        Fix Version/s 3.4.0 [ 12314469 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        332d 15h 3m 1 Andrei Savu 06/Sep/10 07:43


          • Assignee:
            Patrick Hunt
          • Votes:
            0 Vote for this issue
            0 Start watching this issue


            • Created: