Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.1, 3.3.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. CnxnManagerTest.log
      5 kB
      Mahadev konar
    2. ZOOKEEPER-501.patch
      4 kB
      Flavio Junqueira

      Activity

      Mahadev konar added a comment -

      this seems to happen on my 3.2 branch as well (consitently).... Ill post the logs from the test....

      Mahadev konar added a comment -

      the test times out after printing just a few lines.

      Flavio Junqueira added a comment -

      Since I cannot reproduce, I tried to come up with an explanation for the failure of this test. I suspect that due to timing, one cnx manager tried to connect to the other before the other was available to receive connections. Consequently, the patch I propose retries to connect a number of times. It also times out itself instead of waiting for junit to kill it.

      Mahadev konar added a comment -

      +1 the patch passes the tests for me... tahnks flavio ...

      Mahadev konar added a comment -

      [exec] +1 overall.

      [exec] +1 @author. The patch does not contain any @author tags.

      [exec] +1 tests included. The patch appears to include 3 new or modified tests.

      [exec] +1 javadoc. The javadoc tool did not generate any warning messages.

      [exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings.

      [exec] +1 findbugs. The patch does not introduce any new Findbugs warnings.

      [exec] +1 release audit. The applied patch does not increase the total number of release audit warnings.

      ran ant test-patch on my local machine

      Mahadev konar added a comment -

      I just committed this. thanks flavio...

      Hudson added a comment -

      Integrated in ZooKeeper-trunk #409 (See http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/409/)
      . CnxManagerTest failed on hudson. (flavio via mahadev)


        People

        • Assignee:
          Flavio Junqueira
          Reporter:
          Flavio Junqueira
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development