Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-4332

Cannot access children of znode that owns too many znodes

Add voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    Description

      We experience problems with performing any operation (deleteall, get etc.) on a znode that has too many child nodes. In our case, it's above 200k. At the same time jute.max.buffer is 4194304. Increasing it by a few factors doesn't help. This should be either solved by limiting the number of direct znodes allowed by a parameter or by adding a hard limit by default.

      I am attaching some screenshots of the commands and their results. What's interesting the numbers from getAllChildrenNumber and stat (numChildren) commands don't match.

      Attachments

        1. Screen Shot 2021-06-30 at 16.53.04.png
          9 kB
          Emil Kleszcz
        2. Screen Shot 2021-06-30 at 16.52.42.png
          33 kB
          Emil Kleszcz
        3. Screen Shot 2021-06-30 at 16.52.17.png
          19 kB
          Emil Kleszcz

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            ekleszcz Emil Kleszcz

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 1.5h
                1.5h

                Slack

                  Issue deployment