Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-4331

zookeeper artifact is not compatible with OSGi runtime

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

      Description

      Headers likeĀ Bundle-SymbolicName, Import-Package and Export-Package are required by OSGi runtime, but they are no longer available in manifest since 3.5.5.

      The migration from ant to maven looks suspicious, as these headers are originally planted by ant. Either way, they are required for the artifact serving as a bundle directly.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              bigmarvin Marvin Wu

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 6h
                6h

                  Issue deployment