Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0, 3.0.1, 3.1.0
    • Fix Version/s: 3.1.1, 3.2.0
    • Component/s: c client
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The zookeeper_process() function incorrectly calls the c.acl_result member of the completion_list_t structure when handling the completion from a synchronous zoo_get_acl() request. The c.acl_result member is set to SYNCHRONOUS_MARKER, which is a null pointer.

      The attached patch removes this call.

      1. ZOOKEEPER-309.patch
        0.6 kB
        Chris Darroch
      2. ZOOKEEPER-309.patch
        4 kB
        Mahadev konar

        Activity

        Chris Darroch created issue -
        Chris Darroch made changes -
        Field Original Value New Value
        Fix Version/s 3.2.0 [ 12313491 ]
        Status Open [ 1 ] Patch Available [ 10002 ]
        Fix Version/s 3.1.0 [ 12313381 ]
        Affects Version/s 3.0.1 [ 12313500 ]
        Chris Darroch made changes -
        Attachment zookeeper.c.patch [ 12399951 ]
        Benjamin Reed added a comment -

        +1 that's embarrassing!

        Mahadev konar added a comment -

        can we include a test case for this so that we do not get embarrased again?

        Patrick Hunt added a comment -

        Moving from 3.1 to 3.1.1 – this is not a regression and has a workaround (too late in release cycle to address non-blocker for 3.1.0

        Patrick Hunt made changes -
        Fix Version/s 3.1.0 [ 12313381 ]
        Affects Version/s 3.1.0 [ 12313381 ]
        Fix Version/s 3.1.1 [ 12313649 ]
        Affects Version/s 3.0.0 [ 12313216 ]
        Patrick Hunt added a comment -

        Cancelling patch - needs tests. I suggest that tests be added for ACLs in general (not just this api) – the cppunits are missing any kind of acl testing.

        Patrick Hunt made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Chris Darroch added a comment -

        Renamed patch file with issue key.

        Chris Darroch made changes -
        Attachment ZOOKEEPER-309.patch [ 12400535 ]
        Chris Darroch made changes -
        Attachment zookeeper.c.patch [ 12399951 ]
        Mahadev konar made changes -
        Assignee Mahadev konar [ mahadev ]
        Mahadev konar made changes -
        Assignee Mahadev konar [ mahadev ]
        Mahadev konar added a comment -

        this patch adds some tests to chris's patch. The test runs the sync setacl's and getacl's and since both of them use the async version of the set/get acl, it indirectly tests the async versions as well.

        Mahadev konar made changes -
        Attachment ZOOKEEPER-309.patch [ 12401994 ]
        Mahadev konar made changes -
        Assignee Mahadev konar [ mahadev ]
        Mahadev konar made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Mahadev konar added a comment -

        also forgot to mention that the tests fail with segmenetation fault without chris's patch and pass with the patch..

        Patrick Hunt added a comment -

        +1, good to see we are testing acls now in c client.

        Committed revision 752729.
        Committed revision 752730.

        Patrick Hunt made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in ZooKeeper-trunk #253 (See http://hudson.zones.apache.org/hudson/job/ZooKeeper-trunk/253/)

        Patrick Hunt made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Mahadev konar
            Reporter:
            Chris Darroch
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development