Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1963

Make JDK 7 the minimum requirement for Zookeeper

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.5.0
    • Fix Version/s: 3.5.1, 3.6.0
    • Component/s: build
    • Labels:
      None

      Description

      JDK 6 stopped receiving public updates in early 2013:

      http://www.oracle.com/technetwork/java/eol-135779.html

      I propose making JDK 7 the minimum for Zookeeper going forward. One patch that I've personally submitted already would have been a good fit for Java 7's try-with-resources statement, and another pending patch fails to build on versions of Java prior to 7 because a unit test in it uses InetAddress.getLoopbackAddress(), which would be awkward to replace. I'm sure there are many other examples.

        Attachments

        1. ZOOKEEPER-1963.patch
          0.6 kB
          Edward Carter
        2. ZOOKEEPER-1963-v2.patch
          1 kB
          Hongchao Deng

          Issue Links

            Activity

              People

              • Assignee:
                hdeng Hongchao Deng
                Reporter:
                ecarter Edward Carter
              • Votes:
                0 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: