ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-1945

deb - zkCli.sh, zkServer.sh and zkEnv.sh regression caused by ZOOKEEPER-1663

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.6
    • Fix Version/s: 3.4.7, 3.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux (Debian 7) with dash shell

      Description

      This is the same issue as ZOOKEEPER-1719, where the shebang for etc/init.d/zookeeper is set to /bin/sh, but needs to be fixed for deb packages(in src/packages/deb/init.d/zookeeper)

      1. ZOOKEEPER-1945.patch
        0.4 kB
        Mark Flickinger

        Activity

        Mark Flickinger created issue -
        Mark Flickinger added a comment -

        changed src/packages/deb/init.d/zookeeper shebang to

        #!/usr/bin/env bash
        Mark Flickinger made changes -
        Field Original Value New Value
        Attachment ZOOKEEPER-1945.patch [ 12652125 ]
        Mark Flickinger made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12652125/ZOOKEEPER-1945.patch
        against trunk revision 1601516.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2144//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2144//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2144//console

        This message is automatically generated.

        Flavio Junqueira added a comment -

        Yep, looks good, +1. If no one has a concern, I'll check this one in.

        Flavio Junqueira made changes -
        Fix Version/s 3.5.0 [ 12316644 ]
        Flavio Junqueira made changes -
        Affects Version/s 3.4.6 [ 12323310 ]
        Affects Version/s 3.5.0 [ 12316644 ]
        Flavio Junqueira made changes -
        Assignee Mark Flickinger [ maflick88 ]
        Flavio Junqueira added a comment -

        Trunk: Committed revision 1605391.
        Branch 3.4: Committed revision 1605396.

        Flavio Junqueira made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s 3.4.7 [ 12325149 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        SUCCESS: Integrated in ZooKeeper-trunk #2347 (See https://builds.apache.org/job/ZooKeeper-trunk/2347/)
        ZOOKEEPER-1945. deb - zkCli.sh, zkServer.sh and zkEnv.sh regression caused by ZOOKEEPER-1663 (Mark Flickinger via fpj) (fpj: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1605391)

        • /zookeeper/trunk/CHANGES.txt
        • /zookeeper/trunk/src/packages/deb/init.d/zookeeper
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        20m 52s 1 Mark Flickinger 24/Jun/14 05:12
        Patch Available Patch Available Resolved Resolved
        1d 9h 30m 1 Flavio Junqueira 25/Jun/14 14:42

          People

          • Assignee:
            Mark Flickinger
            Reporter:
            Mark Flickinger
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development