Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1745

Wrong Import-Package in the META-INF/MANIFEST.MF of zookeeper 3.4.5 bundle

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.5
    • Fix Version/s: 3.4.6, 3.5.0
    • Component/s: server
    • Labels:
      None
    • Environment:

      Java 7

      Description

      Import-Package: javax.management,org.apache.log4j,org.osgi.framework;v
      ersion="[1.4,2.0)",org.osgi.util.tracker;version="[1.1,2.0)"

      the "org.apache.log4j" should be replaced by "org.slf4j", because from the source codes, zookeeper server classes import org.slf4j.* for logging.

      currently will get:

      Caused by: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
      at org.apache.zookeeper.server.quorum.QuorumPeerConfig.<clinit>(QuorumPeerConfig.java:46)

      when try to create instance for some of its classes in OSGi container (e.g. apache karaf)

        Attachments

          Activity

            People

            • Assignee:
              jbonofre Jean-Baptiste Onofré
              Reporter:
              xldai Xilai Dai
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: