ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-1433

improve ZxidRolloverTest (test seems flakey)

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.3.5
    • Fix Version/s: 3.3.6, 3.4.4, 3.5.0
    • Component/s: tests
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In our jenkins job to run the ZooKeeper unit tests, org.apache.zookeeper.server.ZxidRolloverTest sometimes fails.

      E.g.,

      org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /foo0
      	at org.apache.zookeeper.KeeperException.create(KeeperException.java:90)
      	at org.apache.zookeeper.KeeperException.create(KeeperException.java:42)
      	at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:815)
      	at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:843)
      	at org.apache.zookeeper.server.ZxidRolloverTest.checkNodes(ZxidRolloverTest.java:154)
      	at org.apache.zookeeper.server.ZxidRolloverTest.testRolloverThenRestart(ZxidRolloverTest.java:211)
      
      1. ZOOKEEPER-1433.patch
        7 kB
        Patrick Hunt
      2. ZOOKEEPER-1433_test.out
        920 kB
        Wing Yew Poon

        Activity

        Hudson added a comment -

        Integrated in ZooKeeper-trunk #1512 (See https://builds.apache.org/job/ZooKeeper-trunk/1512/)
        ZOOKEEPER-1433. improve ZxidRolloverTest (test seems flakey) (phunt via henryr) (Revision 1307191)

        Result = SUCCESS
        henry : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1307191
        Files :

        • /zookeeper/trunk/CHANGES.txt
        • /zookeeper/trunk/src/java/test/org/apache/zookeeper/server/ZxidRolloverTest.java
        Henry Robinson added a comment -

        I just committed this to 3.3, 3.4 and 3.5. Thanks Patrick!

        Henry Robinson added a comment -

        +1, looks good to me.

        Mahadev konar added a comment -

        +1 looks good to me... Thanks for fixing this Pat!

        Patrick Hunt added a comment -

        200 additional green runs overnight on this, looks solid.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12520365/ZOOKEEPER-1433.patch
        against trunk revision 1302736.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/1018//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/1018//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/1018//console

        This message is automatically generated.

        Patrick Hunt added a comment -

        This patch fixes the issue. Went from being able to reproduce the flakey test issue on particular hardware once every 10 runs to running more than 100 runs without seeing it again. Getting the client connection handling right turned out to be tricky.

        Wing Yew Poon added a comment -

        stdout from test run.

        Patrick Hunt added a comment -

        Looks like I missed checking that the clients disconnect, then reconnect after restarting the server. In some cases this doesn't happen fast enough and the exist check fails as a result (ie the client hasn't noticed that the server went down/came back).


          People

          • Assignee:
            Patrick Hunt
            Reporter:
            Wing Yew Poon
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development