ZOOKEEPER-729 introduced 'rmr' for recursive 'delete' operations on a given node. Going by the unix convention, wouldn't it be much better if we were to have an 'rm' if there was an 'rmr' added?
The current set is confusing. Or should we have 'delete' and 'deleteall' or summat?
I know this is a nitpick, but I just dislike to see bad keywords used for commands.
I'm OK to produce a backwards-compatible patch if this is acceptable.