ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-1243

New 4lw for short simple monitoring ldck

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 3.3.3, 3.4.0
    • Fix Version/s: None
    • Component/s: server
    • Labels:
      None
    • Release Note:
      Srvr command duplicates.

      Description

      The existing monitoring fails so often due to https://issues.apache.org/jira/browse/ZOOKEEPER-1197 that we need a workaround. This introduces a short 4lw called ldck that just runs ServerStats.toString to get information about the sever's leadership status.

      1. ZOOKEEPER-1243.patch
        5 kB
        Camille Fournier
      2. ZOOKEEPER-1243-2
        5 kB
        Camille Fournier
      3. ZOOKEEPER-1243-4.patch
        6 kB
        Camille Fournier

        Activity

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12500455/ZOOKEEPER-1243.patch
        against trunk revision 1188039.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        -1 javac. The patch appears to cause tar ant target to fail.

        -1 findbugs. The patch appears to cause Findbugs (version 1.3.9) to fail.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/645//testReport/
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/645//console

        This message is automatically generated.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12500457/ZOOKEEPER-1243-2
        against trunk revision 1188039.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/646//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/646//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/646//console

        This message is automatically generated.

        Camille Fournier added a comment -

        Added html docs, removed println in test. Can someone please review this? We've been suffering heavily from ZOOKEEPER-1197 and I would really appreciate it if we could get this in to 3.4

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12500544/ZOOKEEPER-1243-4.patch
        against trunk revision 1188039.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/651//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/651//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/651//console

        This message is automatically generated.

        Patrick Hunt added a comment -

        afaict this is a duplicate of the "srvr" command that already exists in 3.3 and later. Is there a problem using that command? Or did I miss something?

        Camille Fournier added a comment -

        Oh, you are right, I thought it was weird we didn't have this. Why we chose to put the srvr command in the same command thread as stat with the only differentiator be a guarding if statement... Ok I will close this, thanks.

        Patrick Hunt added a comment -

        Thomas also expressed issues with the way the 4lw code is structured. It's certainly ripe for refactoring (hint hint ) esp given the duplication btw NIO/Netty and taking into account the problems you've been finding. Regards.

        Camille Fournier added a comment -

        Indeed... put it on the todo list.


          People

          • Assignee:
            Camille Fournier
            Reporter:
            Camille Fournier
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development