ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-1145

ObserverTest.testObserver fails at particular point after several runs of ant junt.run -Dtestcase=ObserverTest

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.4.0
    • Fix Version/s: 3.4.0
    • Component/s: None
    • Labels:
      None

      Description

      Use the attached repeat.sh to run ObserverTest repeatedly by doing:

      src/repeat.sh ObserverTest

      The test will will fail eventually after a few iterations; should be only a few minutes.

      The line that fails in the test is:

      zk = new ZooKeeper("127.0.0.1:" + CLIENT_PORT_OBS,
      ClientBase.CONNECTION_TIMEOUT, this);

      Attached as out.txt is the output showing a successful run, for comparison, followed by a failed run.

      Note that in the seconds before the test fails, in the following lines, that there is a 24 second gap in time (between 22:13:02 and 22:13:26):

      [junit] 2011-08-03 22:13:02,167 [myid:3] - INFO [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:11229:ZooKeeperServer@833] - Client attempting to establish new session at /127.0.0.1:46929
      [junit] 2011-08-03 22:13:26,003 [myid:2] - INFO [QuorumPeer[myid=2]/0:0:0:0:0:0:0:0:11228:Leader@419] - Shutting down
      [junit] 2011-08-03 22:13:26,003 [myid:2] - INFO [QuorumPeer[myid=2]/0:0:0:0:0:0:0:0:11228:Leader@425] - Shutdown called
      [junit] java.lang.Exception: shutdown Leader! reason: Only 0 followers, need 1

      1. out.txt
        181 kB
        Eugene Koontz
      2. repeat.sh
        0.4 kB
        Eugene Koontz

        Issue Links

          Activity

          Mahadev konar added a comment -

          Marking it as duplicate of ZOOKEEPER-1144.

          Vishal Kher added a comment -


          Great! Thanks for verifying the patch.

          Mahadev konar added a comment -

          thats great news!

          Eugene Koontz added a comment -

          Hi Vishal, Good news. I tried trunk today (commit e9373536) with your patch on a EC-2 m2.xlarge. I ran ObserverTest 300 times and the whole "ant test" 3 times. No errors.

          Vishal Kher added a comment -

          Eugene,

          Can you please verify if patch for ZOOKEEPER-1144 works for you? Thanks.

          Vishal Kher added a comment -

          Error looks similar to what I have been seeing. I reported the cause of the problem here: https://issues.apache.org/jira/browse/ZOOKEEPER-1144

          Eugene Koontz added a comment -

          test console output showing one successful run followed by one failed run.


            People

            • Assignee:
              Vishal Kher
              Reporter:
              Eugene Koontz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development