Uploaded image for project: 'Yetus'
  1. Yetus
  2. YETUS-557

Investigate switching to jdk.javadoc.doclet

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 0.6.0
    • 0.14.0
    • Audience Annotations
    • None
    • Hide
      <!-- markdown -->
      The audience annotations doclet code now requires JDK 11+. Additionally, the default Apache Yetus container no longer has JDK 8.
      Show
      <!-- markdown --> The audience annotations doclet code now requires JDK 11+. Additionally, the default Apache Yetus container no longer has JDK 8.
    • Important

    Description

      It looks like there is a newer API available for building Javadoc doclets. This might help remove our dependency on tools.jar.

      Attachments

        1. YETUS-557.00.patch
          22 kB
          Mike Drob
        2. 0001-Remove-JDK8.patch
          2 kB
          Allen Wittenauer
        3. YETUS-557.01.patch
          33 kB
          Mike Drob

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            mdrob Mike Drob
            aw Allen Wittenauer
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h

                Slack

                  Issue deployment