Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Some stuff that we observed:

      • addFpga() - we check for duplicate devices, but we don't print any error/warning if there's any.
      • findMatchedFpga() should be called findMatchingFpga(). Also, is this method even needed? We already receive an FpgaDevice instance in updateFpga() which I believe is the same that we're looking up.
      • variable IPIDpreference is confusing
      • availableFpga / usedFpgaByRequestor are instances of LinkedHashMap. What's the rationale behind this? Doesn't a simple HashMap suffice?
      • usedFpgaByRequestor should be renamed, naming is a bit unclear
      • allowedFpgas should be an immutable list
      • @VisibleForTesting methods should be package private
      • get rid of * imports

        Attachments

        1. YARN-9269-001.patch
          7 kB
          Peter Bacsko
        2. YARN-9269-002.patch
          8 kB
          Peter Bacsko
        3. YARN-9269-003.patch
          10 kB
          Peter Bacsko
        4. YARN-9269-004.patch
          8 kB
          Peter Bacsko
        5. YARN-9269-005.patch
          8 kB
          Peter Bacsko

          Activity

            People

            • Assignee:
              pbacsko Peter Bacsko
              Reporter:
              pbacsko Peter Bacsko
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: