Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-9046

Fix overlapping netty classes warnings when building YARN CSI module

Add voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • None
    • None

    Description

      
      [*WARNING*] netty-codec-4.1.27.Final.jar, netty-all-4.1.27.Final.jar define 197 overlapping classes: 
      
      [*WARNING*]   - io.netty.handler.codec.compression.ZlibUtil
      
      [*WARNING*]   - io.netty.handler.codec.CharSequenceValueConverter
      
      [*WARNING*]   - io.netty.handler.codec.compression.Bzip2Encoder$3
      
      [*WARNING*]   - io.netty.handler.codec.DefaultHeaders$1
      
      [*WARNING*]   - io.netty.handler.codec.compression.Bzip2BlockDecompressor
      
      [*WARNING*]   - io.netty.handler.codec.compression.Lz4FrameDecoder$1
      
      [*WARNING*]   - io.netty.handler.codec.compression.SnappyFrameDecoder
      
      [*WARNING*]   - io.netty.handler.codec.compression.DecompressionException
      
      [*WARNING*]   - io.netty.handler.codec.compression.Bzip2DivSufSort$TRBudget
      
      [*WARNING*]   - io.netty.handler.codec.compression.Bzip2Decoder$State
      
      [*WARNING*]   - 187 more...
      
      

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            xyao Xiaoyu Yao

            Dates

              Created:
              Updated:

              Slack

                Issue deployment