Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-8276

[UI2] After version field became mandatory, form-based submission of new YARN service doesn't work

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.0, 3.1.1
    • Component/s: yarn-ui-v2
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      After version became mandatory in YARN service, one cannot create a new service through UI, there is no way to specify the version field and the service fails with the following message:

      "Error: Adapter operation failed". 
      

      Checking through browser dev tools, the REST response is the following:

      {"diagnostics":"Version of service sleeper-service is either empty or not provided"}
      

      Discovered by Vinod Kumar Vavilapalli.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                GergelyNovak Gergely Novák
                Reporter:
                GergelyNovak Gergely Novák
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: