Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-117 Enhance YARN service model
  3. YARN-746

rename Service.register() and Service.unregister() to registerServiceListener() & unregisterServiceListener() respectively

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.1.0-beta
    • None
    • None
    • Incompatible change, Reviewed

    Description

      make it clear what you are registering on a Service by naming the methods registerServiceListener() & unregisterServiceListener() respectively.

      This only affects a couple of production classes; Service.register() and is used in some of the lifecycle tests of the YARN-530. There are no tests of Service.unregister(), which is something that could be corrected.

      Attachments

        1. YARN-746-001.patch
          12 kB
          Steve Loughran

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            stevel@apache.org Steve Loughran
            stevel@apache.org Steve Loughran
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment