Hadoop YARN
  1. Hadoop YARN
  2. YARN-70

nodemanager doesn't cleanup old logs/local files after restart

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.23.3
    • Fix Version/s: None
    • Component/s: nodemanager
    • Labels:
      None

      Description

      The nodemanager doesn't ever remove old logs or local files when it is restarted. This is very noticeable if you are using yarn.nodemanager.delete.debug-delay-sec set to > 0 and restart your nodemanager. This could happen in other situations though also, for instance if the node manager crashes/is restarted with running containers.

        Issue Links

          Activity

          Vinod Kumar Vavilapalli added a comment -

          Duplicate of YARN-71.


            People

            • Assignee:
              Unassigned
              Reporter:
              Thomas Graves
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development