Thanks for the review, Eric Badger.
The findbugs isn't related to this JIRA, butI think it's something that we should fix.
YARN-6515. YARN-6968 has been created to track fixing the issue, but I expect we'll remove the reference all together once whitelisted mounts are available.
Is it ok to import static variables one by one or should we just import YarnConfiguration and reference the variables specifically?
Given line length limits and how long some of the config options have become, IMO, it improves readability, but I'll let others comment if there is a strong opinion.
I also wonder whether it would be better/cleaner to iterate through allowedRuntimes and allocate the new objects by class name via reflection instead of hard-coding all of them
I've always tried to reserve reflection for cases where I don't know a class and its functionality at compile time. In this case we do. Again, if there is a strong opinion that the trade off is worth it, I can pursue a patch that leverages reflection.