Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-6654

RollingLevelDBTimelineStore backwards incompatible after fst upgrade

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-beta1, 2.8.2
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      There is a small minor backwards compatible change introduced while upgrading fst library from 2.24 to 2.50.

      Exception in thread "main" java.io.IOException: java.lang.RuntimeException: unable to find class for code 83
      	at org.nustaq.serialization.FSTObjectInput.readObject(FSTObjectInput.java:243)
      	at org.nustaq.serialization.FSTConfiguration.asObject(FSTConfiguration.java:1125)
      	at org.nustaq.serialization.FSTNoJackson.main(FSTNoJackson.java:31)
      Caused by: java.lang.RuntimeException: unable to find class for code 83
      	at org.nustaq.serialization.FSTClazzNameRegistry.decodeClass(FSTClazzNameRegistry.java:180)
      	at org.nustaq.serialization.coders.FSTStreamDecoder.readClass(FSTStreamDecoder.java:472)
      	at org.nustaq.serialization.FSTObjectInput.readClass(FSTObjectInput.java:933)
      	at org.nustaq.serialization.FSTObjectInput.readObjectWithHeader(FSTObjectInput.java:343)
      	at org.nustaq.serialization.FSTObjectInput.readObjectInternal(FSTObjectInput.java:327)
      	at org.nustaq.serialization.serializers.FSTArrayListSerializer.instantiate(FSTArrayListSerializer.java:63)
      	at org.nustaq.serialization.FSTObjectInput.instantiateAndReadWithSer(FSTObjectInput.java:497)
      	at org.nustaq.serialization.FSTObjectInput.readObjectWithHeader(FSTObjectInput.java:366)
      	at org.nustaq.serialization.FSTObjectInput.readObjectInternal(FSTObjectInput.java:327)
      	at org.nustaq.serialization.serializers.FSTMapSerializer.instantiate(FSTMapSerializer.java:78)
      	at org.nustaq.serialization.FSTObjectInput.instantiateAndReadWithSer(FSTObjectInput.java:497)
      	at org.nustaq.serialization.FSTObjectInput.readObjectWithHeader(FSTObjectInput.java:366)
      	at org.nustaq.serialization.FSTObjectInput.readObjectInternal(FSTObjectInput.java:327)
      	at org.nustaq.serialization.FSTObjectInput.readObject(FSTObjectInput.java:307)
      	at org.nustaq.serialization.FSTObjectInput.readObject(FSTObjectInput.java:241)
      
      1. YARN-6654.1.patch
        2 kB
        Jonathan Eagles
      2. YARN-6654.2.patch
        4 kB
        Jonathan Eagles
      3. YARN-6654.3.patch
        5 kB
        Jonathan Eagles

        Activity

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #12002 (See https://builds.apache.org/job/Hadoop-trunk-Commit/12002/)
        YARN-6654. RollingLevelDBTimelineStore backwards incompatible after fst (jlowe: rev 5f1ee72b0ebf0330417b7c0115083bc851923be4)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/main/java/org/apache/hadoop/yarn/server/timeline/RollingLevelDBTimelineStore.java
        jlowe Jason Lowe added a comment -

        Thanks, Jonathan Eagles! I committed this to trunk, branch-2, branch-2.8, and branch-2.8.2.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
              Prechecks
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
              trunk Compile Tests
        +1 mvninstall 13m 8s trunk passed
        +1 compile 0m 20s trunk passed
        +1 checkstyle 0m 13s trunk passed
        +1 mvnsite 0m 22s trunk passed
        +1 findbugs 0m 32s trunk passed
        +1 javadoc 0m 15s trunk passed
              Patch Compile Tests
        +1 mvninstall 0m 19s the patch passed
        +1 compile 0m 20s the patch passed
        +1 javac 0m 20s the patch passed
        +1 checkstyle 0m 12s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice: The patch generated 0 new + 3 unchanged - 2 fixed = 3 total (was 5)
        +1 mvnsite 0m 25s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 50s the patch passed
        +1 javadoc 0m 13s the patch passed
              Other Tests
        +1 unit 3m 16s hadoop-yarn-server-applicationhistoryservice in the patch passed.
        +1 asflicense 0m 19s The patch does not generate ASF License warnings.
        22m 15s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-6654
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12871258/YARN-6654.3.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 918f8e6134a2 3.13.0-116-generic #163-Ubuntu SMP Fri Mar 31 14:13:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 945c095
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16426/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16426/console
        Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jlowe Jason Lowe added a comment -

        Thanks for updating the patch Jonathan Eagles!

        +1 lgtm. Will commit this pending another Jenkins run since it's been a while.

        djp Junping Du added a comment -

        2.8.1 will be a security release. Let's move to 2.8.2.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 13s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 13m 20s trunk passed
        +1 compile 0m 21s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 22s trunk passed
        +1 findbugs 0m 32s trunk passed
        +1 javadoc 0m 15s trunk passed
        +1 mvninstall 0m 18s the patch passed
        +1 compile 0m 17s the patch passed
        +1 javac 0m 17s the patch passed
        +1 checkstyle 0m 11s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice: The patch generated 0 new + 3 unchanged - 2 fixed = 3 total (was 5)
        +1 mvnsite 0m 19s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 36s the patch passed
        +1 javadoc 0m 12s the patch passed
        +1 unit 3m 0s hadoop-yarn-server-applicationhistoryservice in the patch passed.
        +1 asflicense 0m 17s The patch does not generate ASF License warnings.
        21m 57s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-6654
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12871258/YARN-6654.3.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 580c1bda07d5 3.13.0-106-generic #153-Ubuntu SMP Tue Dec 6 15:44:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / abdd609
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16116/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16116/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jeagles Jonathan Eagles added a comment -

        Cleaning up the checkstyle warnings in v3 patch.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 16s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 13m 9s trunk passed
        +1 compile 0m 20s trunk passed
        +1 checkstyle 0m 13s trunk passed
        +1 mvnsite 0m 22s trunk passed
        +1 findbugs 0m 32s trunk passed
        +1 javadoc 0m 14s trunk passed
        +1 mvninstall 0m 18s the patch passed
        +1 compile 0m 17s the patch passed
        +1 javac 0m 17s the patch passed
        -0 checkstyle 0m 11s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice: The patch generated 3 new + 5 unchanged - 0 fixed = 8 total (was 5)
        +1 mvnsite 0m 19s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 36s the patch passed
        +1 javadoc 0m 12s the patch passed
        +1 unit 2m 57s hadoop-yarn-server-applicationhistoryservice in the patch passed.
        +1 asflicense 0m 16s The patch does not generate ASF License warnings.
        21m 29s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-6654
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12871252/YARN-6654.2.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 99b9f88e6b4c 3.13.0-106-generic #153-Ubuntu SMP Tue Dec 6 15:44:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 46f7e91
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/16115/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-applicationhistoryservice.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16115/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16115/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jlowe Jason Lowe added a comment -

        Thanks for the report and patch, Jon! I'm far from an expert on the fst library, and the comment in the code pointing people back to this JIRA doesn't give a lot of details as to why the code in question is necessary. How did you discover class 83 was LinkedHashMap? It's also a bit weird given LinkedHashMap is a java built-in that we need to register it but not other types. Could you elaborate a bit more, preferably in the code comment?

        Otherwise patch looks good. I'm assuming it's a bit difficult to write a test for this short of providing some sample data generated on fst-2.24 that the code tries to load.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 21s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 14m 35s trunk passed
        +1 compile 0m 21s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 22s trunk passed
        +1 mvneclipse 0m 16s trunk passed
        +1 findbugs 0m 34s trunk passed
        +1 javadoc 0m 15s trunk passed
        +1 mvninstall 0m 19s the patch passed
        +1 compile 0m 18s the patch passed
        +1 javac 0m 18s the patch passed
        +1 checkstyle 0m 10s the patch passed
        +1 mvnsite 0m 19s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 36s the patch passed
        +1 javadoc 0m 12s the patch passed
        +1 unit 3m 26s hadoop-yarn-server-applicationhistoryservice in the patch passed.
        +1 asflicense 0m 17s The patch does not generate ASF License warnings.
        24m 9s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-6654
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12869995/YARN-6654.1.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux d507ff7f8d80 3.13.0-116-generic #163-Ubuntu SMP Fri Mar 31 14:13:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 47474ff
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16028/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16028/console
        Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.


          People

          • Assignee:
            jeagles Jonathan Eagles
            Reporter:
            jeagles Jonathan Eagles
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development