Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-6628

Unexpected jackson-core-2.2.3 dependency introduced

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.8.1
    • Fix Version/s: 2.9.0, 2.8.2
    • Component/s: timelineserver
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      The change in YARN-5894 caused jackson-core-2.2.3.jar to be added in share/hadoop/yarn/lib/. This added dependency seems to be incompatible with jackson-core-asl-1.9.13.jar which is also shipped as a dependency. This new jackson-core jar ends up breaking jobs that ran fine on 2.8.0.

      1. YARN-6628.1.patch
        4 kB
        Jonathan Eagles
      2. YARN-6628.2-branch-2.8.patch
        4 kB
        Jonathan Eagles
      3. YARN-6628.3-branch-2.8.patch
        4 kB
        Jonathan Eagles
      4. YARN-6628.4-branch-2.patch
        4 kB
        Jonathan Eagles
      5. YARN-6628.5-branch-2.patch
        4 kB
        Jonathan Eagles

        Issue Links

          Activity

          haibochen Haibo Chen added a comment -

          Based on its pom file, fst depends on jackson-core:2.8.8

                  <!-- required for createJSONConfiguration -->
                  <dependency>
                    <groupId>com.fasterxml.jackson.core</groupId>
                    <artifactId>jackson-core</artifactId>
                    <version>2.8.8</version>
                  </dependency>
          

          It is overridden by the version specified in hadoop-2.8, which is 2.2.3. That's why jackson-core-2.2.3.jar is in share/hadoop/yarn/lib

          \- de.ruedigermoeller:fst:jar:2.50:compile
             +- com.fasterxml.jackson.core:jackson-core:jar:2.2.3:compile (version managed from 2.8.8)
             \- com.cedarsoftware:java-util:jar:1.9.0:compile
                \- com.cedarsoftware:json-io:jar:2.5.1:compile
          

          Strangely enough, according to mvn dependency:tree, jackson-core is not dependent on by fst in trunk

          \- de.ruedigermoeller:fst:jar:2.50:compile
             \- com.cedarsoftware:java-util:jar:1.9.0:compile
                 \- com.cedarsoftware:json-io:jar:2.5.1:compile
          

          and jackson-core.jar is NOT in share/hadoop/yarn/lib/ even though hadoop-yarn-common and other modules depend on it.

          +- org.apache.hadoop:hadoop-yarn-common:jar:3.0.0-alpha3-SNAPSHOT:compile
            +- com.fasterxml.jackson.core:jackson-core:jar:2.7.8:compile
            +- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.7.8:compile
            \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.7.8:compile
               \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.7.8:compile
          

          Any idea how this could have happened?

          haibochen Haibo Chen added a comment -

          Similar for jackson-core-asl, it shows up in the dependency tree in both trunk and branch-2.8, but the jar only shows up in 2.8 branch

          haibochen Haibo Chen added a comment -

          In branch-2.8, find hadoop-dist -name "jackson-core*jar" returns

          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/common/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/hdfs/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/httpfs/tomcat/webapps/webhdfs/WEB-INF/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/kms/tomcat/webapps/kms/WEB-INF/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/mapreduce/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/tools/lib/jackson-core-2.2.3.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/tools/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/yarn/lib/jackson-core-2.2.3.jar
          hadoop-dist/target/hadoop-2.8.2-SNAPSHOT/share/hadoop/yarn/lib/jackson-core-asl-1.9.13.jar
          

          whereas in trunk, the result is

          hadoop-dist/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/common/lib/jackson-core-2.7.8.jar
          hadoop-dist/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/common/lib/jackson-core-asl-1.9.13.jar
          hadoop-dist/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/hdfs/lib/jackson-core-2.7.8.jar
          hadoop-dist/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/hdfs/lib/jackson-core-asl-1.9.13.jar
          
          jlowe Jason Lowe added a comment -

          Other dependency changes associated with the move from fst-2.24 to fst-2.50 include addiing java-util-1.9.0.jar and json-io-2.5.1.jar (in addition to jackson-core-2.23.jar) and the removal of objenesis-2.1.jar.

          As for why jackson-core-2.7.8.jar is missing from hadoop-dist/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib, that's caused by HADOOP-12850. That JIRA changed the way the projects are stitched together, and it only copies dependency jars if they aren't already somewhere else in the tree. See dev-support/bin/dist-layout-stitching for details. The jackson-core-2.7.8.jar is listed in hadoop-yarn-project/target/hadoop-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib, so the fact that it's not in hadoop-dist is an artifact of how the dependencies are copied over.

          The fst dependency on jackson-core says it's needed for createJSONConfiguration. Is it possible that we are not calling that method and do not actually need this dependency in practice?

          jeagles Jonathan Eagles added a comment -

          So we are in a catch-22 since the version of fst the has the matching jackson dependency has the incorrectly advertised license in the gpl (failing rat-check). The version with the correct Apache License in the pom has the newer jackson jars which are something we can't introduce in 2.8.

          I tried what Jason suggested but I was unable to create a FSTConfiguration that didn't trigger a class not found error for com.fasterxml.jackson.

          Instead perhaps we shade the com.fasterxml jackson jar to not expose this to the classpath.

          jeagles Jonathan Eagles added a comment -

          Jason Lowe, this patch YARN-6628.3-branch-2.8.patch works for both branch-2 and branch-2.8.
          For branch 2.8, this patch totally removes (by shading) jackson 2 and fst from user exposure.
          For branch 2, there are new uses of jackson 2 in hdfs.

          I want to unblock the 2.8.2 release, but I want to make sure jackson 2 is remove from HDFS as well.

          jlowe Jason Lowe added a comment -

          Thanks for the patch!

          Shading is far from my first choice, but it seems like we have little other choice unless we can remove the fst dependency completely since we're stuck between a mandatory license upgrade and a mandatory jackson-2 dependency.

          There are some "com.yahoo" prefixes in the shading directives that need to be updated. Also have you verified that shading didn't pick up any undesired settings for META-INF or other items in the jar that could be problematic?

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 23s Docker mode activated.
                Prechecks
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
                branch-2 Compile Tests
          0 mvndep 1m 9s Maven dependency ordering for branch
          +1 mvninstall 7m 15s branch-2 passed
          +1 compile 6m 19s branch-2 passed with JDK v1.8.0_131
          +1 compile 7m 8s branch-2 passed with JDK v1.7.0_131
          +1 checkstyle 1m 30s branch-2 passed
          +1 mvnsite 1m 0s branch-2 passed
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-assemblies
          +1 findbugs 1m 19s branch-2 passed
          +1 javadoc 0m 43s branch-2 passed with JDK v1.8.0_131
          +1 javadoc 0m 44s branch-2 passed with JDK v1.7.0_131
                Patch Compile Tests
          0 mvndep 0m 18s Maven dependency ordering for patch
          +1 mvninstall 0m 50s the patch passed
          +1 compile 5m 51s the patch passed with JDK v1.8.0_131
          +1 javac 5m 51s the patch passed
          +1 compile 6m 48s the patch passed with JDK v1.7.0_131
          +1 javac 6m 48s the patch passed
          +1 checkstyle 1m 28s the patch passed
          +1 mvnsite 1m 9s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 xml 0m 2s The patch has no ill-formed XML file.
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-assemblies
          +1 findbugs 1m 41s the patch passed
          +1 javadoc 0m 51s the patch passed with JDK v1.8.0_131
          +1 javadoc 0m 57s the patch passed with JDK v1.7.0_131
                Other Tests
          +1 unit 0m 14s hadoop-assemblies in the patch passed with JDK v1.7.0_131.
          +1 unit 3m 26s hadoop-yarn-server-applicationhistoryservice in the patch passed with JDK v1.7.0_131.
          +1 unit 0m 59s hadoop-yarn-server-timeline-pluginstorage in the patch passed with JDK v1.7.0_131.
          +1 asflicense 0m 28s The patch does not generate ASF License warnings.
          79m 39s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:5e40efe
          JIRA Issue YARN-6628
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12878024/YARN-6628.4-branch-2.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
          uname Linux cc7dde5e5ebb 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision branch-2 / 1d629c9
          Default Java 1.7.0_131
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_131 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_131
          findbugs v3.0.0
          JDK v1.7.0_131 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16493/testReport/
          modules C: hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage U: .
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/16493/console
          Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          jeagles Jonathan Eagles added a comment -

          Thanks Jason Lowe. Relocated the service loader in the meta info to prevent accidental class not found issues

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 13m 34s Docker mode activated.
                Prechecks
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
                branch-2 Compile Tests
          0 mvndep 1m 3s Maven dependency ordering for branch
          +1 mvninstall 7m 49s branch-2 passed
          +1 compile 6m 30s branch-2 passed with JDK v1.8.0_131
          +1 compile 7m 33s branch-2 passed with JDK v1.7.0_131
          +1 checkstyle 1m 34s branch-2 passed
          +1 mvnsite 1m 5s branch-2 passed
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-assemblies
          +1 findbugs 1m 20s branch-2 passed
          +1 javadoc 0m 41s branch-2 passed with JDK v1.8.0_131
          +1 javadoc 0m 47s branch-2 passed with JDK v1.7.0_131
                Patch Compile Tests
          0 mvndep 0m 19s Maven dependency ordering for patch
          +1 mvninstall 0m 51s the patch passed
          +1 compile 7m 7s the patch passed with JDK v1.8.0_131
          +1 javac 7m 7s the patch passed
          +1 compile 7m 54s the patch passed with JDK v1.7.0_131
          +1 javac 7m 54s the patch passed
          +1 checkstyle 1m 39s the patch passed
          +1 mvnsite 1m 12s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 xml 0m 1s The patch has no ill-formed XML file.
          0 findbugs 0m 0s Skipped patched modules with no Java source: hadoop-assemblies
          +1 findbugs 1m 41s the patch passed
          +1 javadoc 0m 50s the patch passed with JDK v1.8.0_131
          +1 javadoc 0m 56s the patch passed with JDK v1.7.0_131
                Other Tests
          +1 unit 0m 15s hadoop-assemblies in the patch passed with JDK v1.7.0_131.
          +1 unit 3m 17s hadoop-yarn-server-applicationhistoryservice in the patch passed with JDK v1.7.0_131.
          +1 unit 0m 57s hadoop-yarn-server-timeline-pluginstorage in the patch passed with JDK v1.7.0_131.
          +1 asflicense 0m 28s The patch does not generate ASF License warnings.
          96m 23s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:5e40efe
          JIRA Issue YARN-6628
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12878427/YARN-6628.5-branch-2.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
          uname Linux 05deef58b398 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision branch-2 / c12bf9a
          Default Java 1.7.0_131
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_131 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_131
          findbugs v3.0.0
          JDK v1.7.0_131 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16520/testReport/
          modules C: hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-timeline-pluginstorage U: .
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/16520/console
          Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          jlowe Jason Lowe added a comment -

          Thanks for updating the patch!

          +1 lgtm. Committing this.

          jlowe Jason Lowe added a comment -

          Thanks, Jonathan Eagles! I committed this to branch-2, branch-2.8, and branch-2.8.2.


            People

            • Assignee:
              jeagles Jonathan Eagles
              Reporter:
              jlowe Jason Lowe
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development