Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: yarn-native-services
    • Component/s: None
    • Labels:
      None

      Description

      YARN-6160 started some work enabling different validation for each native services provider. The validation done in ServiceApiUtil#validateApplicationPayload needs to updated accordingly. This validation should also be updated to handle the APPLICATION artifact type, which does not have an associated provider.

        Attachments

        1. YARN-6613-yarn-native-services.006.patch
          160 kB
          Billie Rinaldi
        2. YARN-6613-yarn-native-services.005.patch
          138 kB
          Billie Rinaldi
        3. YARN-6613-yarn-native-services.004.patch
          105 kB
          Billie Rinaldi
        4. YARN-6613-yarn-native-services.003.patch
          103 kB
          Billie Rinaldi
        5. YARN-6613-yarn-native-services.002.patch
          78 kB
          Billie Rinaldi
        6. YARN-6613-yarn-native-services.001.patch
          68 kB
          Billie Rinaldi

          Issue Links

            Activity

              People

              • Assignee:
                billie.rinaldi Billie Rinaldi
                Reporter:
                billie.rinaldi Billie Rinaldi
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: