Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-3368 [Umbrella] YARN web UI: Next generation
  3. YARN-6362

Use frontend-maven-plugin 0.0.22 version for new yarn ui

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha4
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Building yarn-ui module fails due to invalid npm-cli.js path.

      $ mvn clean install -DskipTests -Dtar -Pdist  -Pyarn-ui
      

      Failure of exec-maven-plugin in yarn-ui profile.

      [INFO] --- exec-maven-plugin:1.3.1:exec (ember build) @ hadoop-yarn-ui ---
      module.js:327
          throw err;
          ^
      
      Error: Cannot find module '/Users/sasakikai/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node/npm/bin/npm-cli'
          at Function.Module._resolveFilename (module.js:325:15)
          at Function.Module._load (module.js:276:25)
          at Function.Module.runMain (module.js:441:10)
      

        Attachments

        1. YARN-6362.02.patch
          1 kB
          Sunil G
        2. YARN-6362.01.patch
          0.7 kB
          Kai

          Activity

            People

            • Assignee:
              lewuathe Kai
              Reporter:
              lewuathe Kai
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: