Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-5523

Yarn running container log fetching causes OutOfMemoryError

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: log-aggregation
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Fetching a 256MB log from container caused OOM on client

      [hive@ctr-e20-1468887904486-0007-01-000003 ~]$ yarn logs -applicationId application_1470931023753_0001 -log_files log_2016-08-11-21_3.done > logs
      16/08/11 21:58:11 INFO impl.TimelineClientImpl: Timeline service address: http://ctr-e20-1468887904486-0007-01-000003.hwx.site:8188/ws/v1/timeline/
      16/08/11 21:58:11 INFO client.RMProxy: Connecting to ResourceManager at ctr-e20-1468887904486-0007-01-000003.hwx.site/172.27.8.192:8050
      16/08/11 21:58:12 INFO client.AHSProxy: Connecting to Application History server at ctr-e20-1468887904486-0007-01-000003.hwx.site/172.27.8.192:10200
      Can not find any log file matching the pattern: [log_2016-08-11-21_3.done] for the container: container_e04_1470931023753_0001_01_000001 within the application: application_1470931023753_0001
      Can not find any log file matching the pattern: [log_2016-08-11-21_3.done] for the container: container_e04_1470931023753_0001_01_000002 within the application: application_1470931023753_0001
      Can not find any log file matching the pattern: [log_2016-08-11-21_3.done] for the container: container_e04_1470931023753_0001_01_000003 within the application: application_1470931023753_0001
      Can not find any log file matching the pattern: [log_2016-08-11-21_3.done] for the container: container_e04_1470931023753_0001_01_000004 within the application: application_1470931023753_0001
      Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Arrays.java:3332)
        at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:137)
        at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.java:121)
        at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:569)
        at java.lang.StringBuilder.append(StringBuilder.java:190)
        at com.sun.jersey.core.util.ReaderWriter.readFromAsString(ReaderWriter.java:172)
        at com.sun.jersey.core.util.ReaderWriter.readFromAsString(ReaderWriter.java:157)
        at com.sun.jersey.core.provider.AbstractMessageReaderWriterProvider.readFromAsString(AbstractMessageReaderWriterProvider.java:114)
        at com.sun.jersey.core.impl.provider.entity.StringProvider.readFrom(StringProvider.java:73)
        at com.sun.jersey.core.impl.provider.entity.StringProvider.readFrom(StringProvider.java:58)
        at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:553)
        at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:506)
        at org.apache.hadoop.yarn.client.cli.LogsCLI.printContainerLogsFromRunningApplication(LogsCLI.java:477)
        at org.apache.hadoop.yarn.client.cli.LogsCLI.fetchApplicationLogs(LogsCLI.java:950)
        at org.apache.hadoop.yarn.client.cli.LogsCLI.runCommand(LogsCLI.java:280)
        at org.apache.hadoop.yarn.client.cli.LogsCLI.run(LogsCLI.java:102)
        at org.apache.hadoop.yarn.client.cli.LogsCLI.main(LogsCLI.java:307)
      
      1. YARN-5523.1.patch
        3 kB
        Xuan Gong
      2. YARN-5523.branch-2.2.patch
        12 kB
        Varun Saxena
      3. YARN-5523.branch-2.2.patch
        11 kB
        Xuan Gong
      4. YARN-5523.trunk.1.patch
        3 kB
        Xuan Gong
      5. YARN-5523.trunk.2.patch
        11 kB
        Xuan Gong
      6. YARN-5523.trunk.3.patch
        12 kB
        Varun Saxena
      7. YARN-5523.trunk.3.patch
        12 kB
        Xuan Gong

        Activity

        xgong Xuan Gong added a comment -

        We should use stream output instead of directly calling println which can avoid this oom issue.

        The patch did not add any unit test cases given that we did not have any functional unit tests for fetching logs from running container. But I did the manual test to make sure the fix works.
        1) Run sleep job
        2) override YARN_CLIENT_OPTS and set a very low Xmx value
        3) run yarn logs command (without the fix), and we could see the exact oom exception as shown in the description
        4) run yarn logs command (with the fix), and we could not see the oom exception anymore.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 14s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 8m 1s trunk passed
        +1 compile 0m 24s trunk passed
        +1 checkstyle 0m 16s trunk passed
        +1 mvnsite 0m 27s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 33s trunk passed
        +1 javadoc 0m 16s trunk passed
        +1 mvninstall 0m 20s the patch passed
        +1 compile 0m 18s the patch passed
        -1 javac 0m 18s hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client generated 1 new + 1 unchanged - 0 fixed = 2 total (was 1)
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 26s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 38s the patch passed
        +1 javadoc 0m 12s the patch passed
        -1 unit 16m 2s hadoop-yarn-client in the patch failed.
        +1 asflicense 0m 15s The patch does not generate ASF License warnings.
        29m 42s



        Reason Tests
        Failed junit tests hadoop.yarn.client.api.impl.TestYarnClient



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12823730/YARN-5523.1.patch
        JIRA Issue YARN-5523
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 68ea68d9121f 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 2424911
        Default Java 1.8.0_101
        findbugs v3.0.0
        javac https://builds.apache.org/job/PreCommit-YARN-Build/12772/artifact/patchprocess/diff-compile-javac-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/12772/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/12772/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12772/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12772/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        varun_saxena Varun Saxena added a comment -

        Thanks Xuan Gong for the patch. As such the patch looks fine.
        A couple of comments :

        • ClientResponse#getClientResponseStatus is deprecated. ClientResponse#getStatusInfo can be used instead.
        • If response status is not 200 OK, we print below now. I think response from server can be printed here, as we were doing earlier. NMWebServices seems to pass on the exception message too which will give more details.
           
          out.println("Can not get any logs for the log file: " + logFile);
          
        xgong Xuan Gong added a comment -

        Thanks for the review, Varun Saxena.
        Attached a new patch to address your comments.

        I am not able to write a testcase for this. At least, the way I used to reproduce it manually can not be used in unit testcases. Looks like the Xmx is the JVM opts.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 6m 40s trunk passed
        +1 compile 0m 20s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 24s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 28s trunk passed
        +1 javadoc 0m 15s trunk passed
        +1 mvninstall 0m 17s the patch passed
        +1 compile 0m 17s the patch passed
        +1 javac 0m 17s the patch passed
        +1 checkstyle 0m 12s the patch passed
        +1 mvnsite 0m 22s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 33s the patch passed
        +1 javadoc 0m 13s the patch passed
        -1 unit 15m 56s hadoop-yarn-client in the patch failed.
        +1 asflicense 0m 15s The patch does not generate ASF License warnings.
        27m 47s



        Reason Tests
        Failed junit tests hadoop.yarn.client.api.impl.TestYarnClient



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12823931/YARN-5523.trunk.1.patch
        JIRA Issue YARN-5523
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e8128af22808 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / b427ce1
        Default Java 1.8.0_101
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/12786/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/12786/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12786/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12786/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        varun_saxena Varun Saxena added a comment -

        Latest patch LGTM. Will commit it by tomorrow unless there are further comments.

        I am not able to write a testcase for this.

        The patch should work but I will verify it as well before committing it.

        xgong Xuan Gong added a comment -

        Thanks for the review. Varun Saxena

        I have uploaded a new patch which added a unit testcase to verify whether we could get running container logs correctly. I also created a same patch for branch-2.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 42s trunk passed
        +1 compile 0m 21s trunk passed
        +1 checkstyle 0m 15s trunk passed
        +1 mvnsite 0m 24s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 28s trunk passed
        +1 javadoc 0m 14s trunk passed
        +1 mvninstall 0m 19s the patch passed
        +1 compile 0m 17s the patch passed
        -1 javac 0m 17s hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client generated 1 new + 1 unchanged - 0 fixed = 2 total (was 1)
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 21s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 34s the patch passed
        +1 javadoc 0m 12s the patch passed
        -1 unit 15m 54s hadoop-yarn-client in the patch failed.
        +1 asflicense 0m 17s The patch does not generate ASF License warnings.
        27m 54s



        Reason Tests
        Failed junit tests hadoop.yarn.client.api.impl.TestYarnClient
          hadoop.yarn.client.cli.TestLogsCLI



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12824000/YARN-5523.trunk.2.patch
        JIRA Issue YARN-5523
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 3350f7bca92c 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6c154ab
        Default Java 1.8.0_101
        findbugs v3.0.0
        javac https://builds.apache.org/job/PreCommit-YARN-Build/12796/artifact/patchprocess/diff-compile-javac-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/12796/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/12796/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12796/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12796/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        xgong Xuan Gong added a comment -

        The testcase failure can not be produced locally. Will investigate more

        varun_saxena Varun Saxena added a comment -

        Xuan Gong, the test failure is related. This is because getClientResponseStatus has been used in test instead of getStatusInfo

        xgong Xuan Gong added a comment -

        Varun Saxena
        Yes, I found that, too. Attached a new patch for trunk to fix this. The patch for branch-2 is fine.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 16s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 41s trunk passed
        +1 compile 0m 21s trunk passed
        +1 checkstyle 0m 15s trunk passed
        +1 mvnsite 0m 25s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 28s trunk passed
        +1 javadoc 0m 15s trunk passed
        +1 mvninstall 0m 19s the patch passed
        +1 compile 0m 17s the patch passed
        +1 javac 0m 17s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 23s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 35s the patch passed
        +1 javadoc 0m 12s the patch passed
        -1 unit 15m 56s hadoop-yarn-client in the patch failed.
        +1 asflicense 0m 16s The patch does not generate ASF License warnings.
        27m 56s



        Reason Tests
        Failed junit tests hadoop.yarn.client.api.impl.TestYarnClient



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12824214/YARN-5523.trunk.3.patch
        JIRA Issue YARN-5523
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux a1d06fcf260d 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / f80a729
        Default Java 1.8.0_101
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/12810/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/12810/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12810/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/12810/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        varun_saxena Varun Saxena added a comment -

        Committing this shortly.
        Test failures to be tracked by YARN-5389.
        Verified the fix by testing as well.

        varun_saxena Varun Saxena added a comment -

        I made trivial modification to patch before committing it. A comment was repeated both inside getMatchedContainerLogFiles method and outside it. So removed one occurrence. As the change was insignificant, I made the change myself. I have updated patch with that change.

        varun_saxena Varun Saxena added a comment -

        Committed to trunk, branch-2
        Thanks Xuan Gong for your contribution and Prasanth Jayachandran for raising the issue.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10292 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10292/)
        YARN-5523. Yarn running container log fetching causes OutOfMemoryError (varunsaxena: rev e3037c564117fe53742c130665b047dd17eff6d0)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/LogsCLI.java
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestLogsCLI.java

          People

          • Assignee:
            xgong Xuan Gong
            Reporter:
            prasanth_j Prasanth Jayachandran
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development