Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-5440

Use AHSClient in YarnClient when TimelineServer is running

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In YarnClient, depends on whether we enable yarn.timeline-service.generic-application-history.enabled, the AHSClient will be used or not. But the AHSClientService is enabled by default when we start the TimelineServer which means we are able to get history information for applications/applicationAttempts/containers by using ahsClient when the TimelineServer is running. So, we do not have to rely on this deprecated configuration to get history information by using YarnClient.

        Issue Links

          Activity

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 14s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 17s trunk passed
          +1 compile 0m 23s trunk passed
          +1 checkstyle 0m 17s trunk passed
          +1 mvnsite 0m 28s trunk passed
          +1 mvneclipse 0m 15s trunk passed
          +1 findbugs 0m 32s trunk passed
          +1 javadoc 0m 18s trunk passed
          +1 mvninstall 0m 20s the patch passed
          +1 compile 0m 20s the patch passed
          +1 javac 0m 20s the patch passed
          +1 checkstyle 0m 12s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client: The patch generated 0 new + 30 unchanged - 1 fixed = 30 total (was 31)
          +1 mvnsite 0m 26s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 41s the patch passed
          +1 javadoc 0m 13s the patch passed
          -1 unit 8m 23s hadoop-yarn-client in the patch failed.
          +1 asflicense 0m 15s The patch does not generate ASF License warnings.
          22m 28s



          Reason Tests
          Failed junit tests hadoop.yarn.client.api.impl.TestYarnClient



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:9560f25
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12820549/YARN-5440.1.patch
          JIRA Issue YARN-5440
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux f0fa7c32b47a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 54fe17a
          Default Java 1.8.0_101
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/12527/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/12527/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client.txt
          Test Results https://builds.apache.org/job/PreCommit-YARN-Build/12527/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/12527/console
          Powered by Apache Yetus 0.3.0 http://yetus.apache.org

          This message was automatically generated.

          xgong Xuan Gong added a comment -

          The testcase failures are not related

          gtCarrera9 Li Lu added a comment -

          I cannot reproduce the UT failure locally either. Xuan Gong could you please open a separate JIRA to trace the UT failure?

          Patch generally LGTM. One question is that what will happen if the user turn off timeline service but enable AHS in the config?

          djp Junping Du added a comment -

          if the user turn off timeline service but enable AHS in the config.

          In my understanding, if we enable AHS config but turn of timeline service, we will still create AHSClient to get finished application container information. The only different w/o the patch here is: this new added feature (log CLI enhancement) in 2.9 don't have to work by explicitly set a deprecated configuration of AHS. Instead, it also work with enabling ATS only. Xuan Gong, can you confirm this?

          xgong Xuan Gong added a comment -

          Thanks for the review. Li Lu

          Created https://issues.apache.org/jira/browse/YARN-5442 to track the testcase failures.

          if the user turn off timeline service but enable AHS in the config.

          So, the configuration: yarn.timeline-service.generic-application-history.enabled is deprecated configuration which means we could remove this configuration without any impact (If i understand the deprecate correctly). In current code base, this configuration controls whether we could get the full information (include current and history) for the apps/attempts/containers by using YarnClient. But the pre-requirement is that we have to run the TimelineServer. If we turn off the timeline server but enable AHS, it would give the connection exception because it tries to connect the ATS.

          gtCarrera9 Li Lu added a comment -

          Thanks Xuan Gong! LGTM. +1 for commit.

          gtCarrera9 Li Lu added a comment -

          Will commit shortly.

          gtCarrera9 Li Lu added a comment -

          Committed into trunk and branch-2. Thanks Xuan Gong for the work and Junping Du for the review!

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #10169 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10169/)
          YARN-5440. Use AHSClient in YarnClient when TimelineServer is running. (gtcarrera9: rev 26de4f0de789f58736d1dc383125cffb54debdd0)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/api/impl/YarnClientImpl.java

            People

            • Assignee:
              xgong Xuan Gong
              Reporter:
              xgong Xuan Gong
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development