YARN-3092 introduced ResourceUsage class to track a number of things around resources. The naming is a little ambiguous and hence less conducive to being used elsewhere.
- UsageByLabel doesn't need to be label specific. A more descriptive name (TenantResourceTracker) might be more apt - since the class tracks more than just usage.
- Accordingly, ResourceUsage itself can be renamed to more descriptive (and less ambiguous) to LabelWiseTenantResourceTracker or some such.
- TenantResourceTracker (previously UsageByLabel) should probably be a class on its own, and the private ResourceType should be part of it instead of the mapping against labels.
- Ideally, would like for the names to say allocation to capture allocation instead of usage.