Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4810

NM applicationpage cause internal error 500

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Use url <NODE HTTP IP PORT>/node/application/<appid>

      Case 1

      Caused by: java.lang.NullPointerException
              at org.apache.hadoop.yarn.server.nodemanager.webapp.dao.AppInfo.<init>(AppInfo.java:45)
              at org.apache.hadoop.yarn.server.nodemanager.webapp.ApplicationPage$ApplicationBlock.render(ApplicationPage.java:82)
              at org.apache.hadoop.yarn.webapp.view.HtmlBlock.render(HtmlBlock.java:69)
              at org.apache.hadoop.yarn.webapp.view.HtmlBlock.renderPartial(HtmlBlock.java:79)
              at org.apache.hadoop.yarn.webapp.View.render(View.java:235)
              at org.apache.hadoop.yarn.webapp.view.HtmlPage$Page.subView(HtmlPage.java:49)
              at org.apache.hadoop.yarn.webapp.hamlet.HamletImpl$EImp._v(HamletImpl.java:117)
              at org.apache.hadoop.yarn.webapp.hamlet.Hamlet$TD._(Hamlet.java:848)
              at org.apache.hadoop.yarn.webapp.view.TwoColumnLayout.render(TwoColumnLayout.java:71)
              at org.apache.hadoop.yarn.webapp.view.HtmlPage.render(HtmlPage.java:82)
              at org.apache.hadoop.yarn.webapp.Controller.render(Controller.java:212)
              at org.apache.hadoop.yarn.server.nodemanager.webapp.NMController.application(NMController.java:58)
              ... 44 more
      
      

      Case 2

              at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
      Caused by: java.util.NoSuchElementException
              at com.google.common.base.AbstractIterator.next(AbstractIterator.java:75)
              at org.apache.hadoop.yarn.util.ConverterUtils.toApplicationId(ConverterUtils.java:131)
              at org.apache.hadoop.yarn.util.ConverterUtils.toApplicationId(ConverterUtils.java:126)
              at org.apache.hadoop.yarn.server.nodemanager.webapp.ApplicationPage$ApplicationBlock.render(ApplicationPage.java:79)
              at org.apache.hadoop.yarn.webapp.view.HtmlBlock.render(HtmlBlock.java:69)
              at org.apache.hadoop.yarn.webapp.view.HtmlBlock.renderPartial(HtmlBlock.java:79)
              at org.apache.hadoop.yarn.webapp.View.render(View.java:235)
              at org.apache.hadoop.yarn.webapp.view.HtmlPage$Page.subView(HtmlPage.java:49)
              at org.apache.hadoop.yarn.webapp.hamlet.HamletImpl$EImp._v(HamletImpl.java:117)
              at org.apache.hadoop.yarn.webapp.hamlet.Hamlet$TD._(Hamlet.java:848)
              at org.apache.hadoop.yarn.webapp.view.TwoColumnLayout.render(TwoColumnLayout.java:71)
              at org.apache.hadoop.yarn.webapp.view.HtmlPage.render(HtmlPage.java:82)
              at org.apache.hadoop.yarn.webapp.Controller.render(Controller.java:212)
              at org.apache.hadoop.yarn.server.nodemanager.webapp.NMController.application(NMController.java:58)
              ... 44 more
      
      
      1. 0001-YARN-4810.patch
        6 kB
        Bibin A Chundatt
      2. 0002-YARN-4810.patch
        6 kB
        Bibin A Chundatt
      3. 1.png
        72 kB
        Bibin A Chundatt
      4. 2.png
        64 kB
        Bibin A Chundatt

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9597 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9597/)
        YARN-4810. NM applicationpage cause internal error 500. Contributed by (naganarasimha_gr: rev 437e9d6475a91cafc4c993b206312912b5f13ad9)

        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/webapp/TestNMAppsPage.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/webapp/ApplicationPage.java
        Naganarasimha Naganarasimha G R added a comment -

        Have committed it to branch-2 and trunk. Thanks for the contributions Bibin A Chundatt

        Naganarasimha Naganarasimha G R added a comment -

        Thanks Bibin A Chundatt for the patch, lgtm +1. Will wait for some time before committing it.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 12m 24s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 23s trunk passed
        +1 compile 0m 21s trunk passed with JDK v1.8.0_77
        +1 compile 0m 24s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 16s trunk passed
        +1 mvnsite 0m 27s trunk passed
        +1 mvneclipse 0m 12s trunk passed
        +1 findbugs 0m 48s trunk passed
        +1 javadoc 0m 17s trunk passed with JDK v1.8.0_77
        +1 javadoc 0m 21s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 23s the patch passed
        +1 compile 0m 20s the patch passed with JDK v1.8.0_77
        +1 javac 0m 20s the patch passed
        +1 compile 0m 23s the patch passed with JDK v1.7.0_95
        +1 javac 0m 23s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 24s the patch passed
        +1 mvneclipse 0m 10s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 58s the patch passed
        -1 javadoc 1m 26s hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77 with JDK v1.8.0_77 generated 3 new + 97 unchanged - 3 fixed = 100 total (was 100)
        +1 javadoc 0m 14s the patch passed with JDK v1.8.0_77
        +1 javadoc 0m 19s the patch passed with JDK v1.7.0_95
        -1 unit 8m 54s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.8.0_77.
        -1 unit 9m 29s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.7.0_95.
        +1 asflicense 0m 16s Patch does not generate ASF License warnings.
        44m 53s



        Reason Tests
        JDK v1.8.0_77 Failed junit tests hadoop.yarn.server.nodemanager.containermanager.TestNMProxy
        JDK v1.7.0_95 Failed junit tests hadoop.yarn.server.nodemanager.containermanager.TestNMProxy



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12796982/0002-YARN-4810.patch
        JIRA Issue YARN-4810
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 6e54ef55ecb5 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 818d6b7
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        javadoc hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77: https://builds.apache.org/job/PreCommit-YARN-Build/10964/artifact/patchprocess/diff-javadoc-javadoc-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10964/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10964/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_95.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10964/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-YARN-Build/10964/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_95.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10964/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10964/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        Naganarasimha G R
        Thank you for looking into patch.
        Attached latest patch after handling all comments.

        Naganarasimha Naganarasimha G R added a comment -

        Thanks for working on this Bibin A Chundatt, Overall patch seems to be fine Java doc and test case failures does not relate to the patch given.
        Few small nits :

        1. testNMAppsPageWithCompletedApps => testNMAppsPage should be fine
        2. Space is required before application ".Application might have completed" And line could be better formed as "Application might have been completed"
        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 10s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 25s trunk passed
        +1 compile 0m 27s trunk passed with JDK v1.8.0_77
        +1 compile 0m 26s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 17s trunk passed
        +1 mvnsite 0m 30s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 0m 57s trunk passed
        +1 javadoc 0m 18s trunk passed with JDK v1.8.0_77
        +1 javadoc 0m 23s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 25s the patch passed
        +1 compile 0m 21s the patch passed with JDK v1.8.0_77
        +1 javac 0m 21s the patch passed
        +1 compile 0m 25s the patch passed with JDK v1.7.0_95
        +1 javac 0m 25s the patch passed
        +1 checkstyle 0m 14s the patch passed
        +1 mvnsite 0m 28s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 9s the patch passed
        -1 javadoc 1m 43s hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77 with JDK v1.8.0_77 generated 3 new + 97 unchanged - 3 fixed = 100 total (was 100)
        +1 javadoc 0m 17s the patch passed with JDK v1.8.0_77
        +1 javadoc 0m 21s the patch passed with JDK v1.7.0_95
        -1 unit 9m 9s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.8.0_77.
        -1 unit 9m 41s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.7.0_95.
        +1 asflicense 0m 17s Patch does not generate ASF License warnings.
        35m 5s



        Reason Tests
        JDK v1.8.0_77 Failed junit tests hadoop.yarn.server.nodemanager.containermanager.TestNMProxy
        JDK v1.7.0_95 Failed junit tests hadoop.yarn.server.nodemanager.containermanager.TestNMProxy



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12796969/0001-YARN-4810.patch
        JIRA Issue YARN-4810
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 89beeac87c62 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 818d6b7
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        javadoc hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77: https://builds.apache.org/job/PreCommit-YARN-Build/10963/artifact/patchprocess/diff-javadoc-javadoc-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10963/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10963/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_95.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10963/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-YARN-Build/10963/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.7.0_95.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10963/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10963/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        Attaching patch and images, Please do review


          People

          • Assignee:
            bibinchundatt Bibin A Chundatt
            Reporter:
            bibinchundatt Bibin A Chundatt
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development