Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: resourcemanager
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The metrics2 system was implemented to deal with persistent sources. ContainerMetrics is an ephemeral source, and so it causes problems. Specifically, the ContainerMetrics only reports metrics once after the container has been stopped. This behavior is a problem because the metrics2 system can ask sources for reports that will be quietly dropped by the sinks that care. (It's a metrics2 feature, not a bug.) If that final report is silently dropped, it's lost, because the ContainerMetrics won't report anything else ever anymore.

      1. YARN-4795.001.patch
        4 kB
        Daniel Templeton
      2. YARN-4795.002.patch
        4 kB
        Daniel Templeton

        Issue Links

          Activity

          templedf Daniel Templeton added a comment -

          OK, finally got around to testing that the patch works as advertised.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 15s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 47s trunk passed
          +1 compile 0m 25s trunk passed with JDK v1.8.0_74
          +1 compile 0m 26s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 15s trunk passed
          +1 mvnsite 0m 28s trunk passed
          +1 mvneclipse 0m 12s trunk passed
          +1 findbugs 0m 51s trunk passed
          +1 javadoc 0m 19s trunk passed with JDK v1.8.0_74
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 24s the patch passed
          +1 compile 0m 21s the patch passed with JDK v1.8.0_74
          +1 javac 0m 21s the patch passed
          +1 compile 0m 24s the patch passed with JDK v1.7.0_95
          +1 javac 0m 24s the patch passed
          +1 checkstyle 0m 13s the patch passed
          +1 mvnsite 0m 26s the patch passed
          +1 mvneclipse 0m 11s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 3s the patch passed
          +1 javadoc 0m 17s the patch passed with JDK v1.8.0_74
          +1 javadoc 0m 19s the patch passed with JDK v1.7.0_95
          +1 unit 9m 23s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_74.
          +1 unit 10m 9s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_95.
          +1 asflicense 0m 20s Patch does not generate ASF License warnings.
          34m 50s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fbe3e86
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12793202/YARN-4795.001.patch
          JIRA Issue YARN-4795
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 6bf5bc037e48 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 33239c9
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_74 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10821/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10821/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          kasha Karthik Kambatla added a comment -

          Thanks for reporting and working on this, Daniel.

          TestContainerMetrics part of the patch doesn't apply any more. One comment on the patch: is it possible that flushOnPeriod and finished are both true? If yes, looks like we would schedule another task unnecessarily. How about updating the check from if (flushOnPeriod) to if (flushOnPeriod && !finished)? That mimics the previous version better too.

          kasha Karthik Kambatla added a comment -

          Canceling patch to address review comments.

          templedf Daniel Templeton added a comment -

          Nice catch. Here's a rebased patch that addresses the issues.

          rchiang Ray Chiang added a comment -

          Looks like the Jenkins jobs needs to be re-launched or a new (same) patch uploaded.

          rchiang Ray Chiang added a comment -

          Looks like re-launches only work when the patch status is "Patch Available":

          https://builds.apache.org/job/PreCommit-YARN-Build/11211/consoleText

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 13s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 50s trunk passed
          +1 compile 0m 21s trunk passed with JDK v1.8.0_92
          +1 compile 0m 26s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 16s trunk passed
          +1 mvnsite 0m 28s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 0m 50s trunk passed
          +1 javadoc 0m 17s trunk passed with JDK v1.8.0_92
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 24s the patch passed
          +1 compile 0m 20s the patch passed with JDK v1.8.0_92
          +1 javac 0m 20s the patch passed
          +1 compile 0m 24s the patch passed with JDK v1.7.0_95
          +1 javac 0m 24s the patch passed
          +1 checkstyle 0m 13s the patch passed
          +1 mvnsite 0m 25s the patch passed
          +1 mvneclipse 0m 11s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 1s the patch passed
          +1 javadoc 0m 14s the patch passed with JDK v1.8.0_92
          +1 javadoc 0m 19s the patch passed with JDK v1.7.0_95
          +1 unit 11m 8s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_92.
          +1 unit 11m 39s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_95.
          +1 asflicense 0m 18s Patch does not generate ASF License warnings.
          37m 50s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fbe3e86
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12800548/YARN-4795.002.patch
          JIRA Issue YARN-4795
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux d9a4c4837457 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / a5fed8b
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_92 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/11218/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/11218/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          kasha Karthik Kambatla added a comment -

          +1, checking this in.

          kasha Karthik Kambatla added a comment -

          Thanks for the contribution, Daniel. Just committed this to trunk and branch-2.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9670 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9670/)
          YARN-4795. ContainerMetrics drops records. (Daniel Templeton via kasha) (kasha: rev 1a3f1482e2738c7f9a983bc55189116930388d7b)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/monitor/TestContainerMetrics.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/monitor/ContainerMetrics.java

            People

            • Assignee:
              templedf Daniel Templeton
              Reporter:
              templedf Daniel Templeton
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development