Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4762

NMs failing on DelegatingLinuxContainerRuntime init with LCE on

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Fixed CgroupHandler's creation and usage to avoid NodeManagers crashing when LinuxContainerExecutor is enabled.

      Description

      Seeing this exception and the NMs crash.

      2016-03-03 16:47:57,807 DEBUG org.apache.hadoop.service.AbstractService: Service org.apache.hadoop.yarn.server.nodemanager.recovery.NMLeveldbStateStoreService is started
      2016-03-03 16:47:58,027 DEBUG org.apache.hadoop.yarn.server.nodemanager.LinuxContainerExecutor: checkLinuxExecutorSetup: [/hadoop/hadoop-yarn-nodemanager/bin/container-executor, --checksetup]
      2016-03-03 16:47:58,043 ERROR org.apache.hadoop.yarn.server.nodemanager.containermanager.linux.resources.CGroupsHandlerImpl: Mount point Based on mtab file: /proc/mounts. Controller mount point not writable for: cpu
      2016-03-03 16:47:58,043 ERROR org.apache.hadoop.yarn.server.nodemanager.containermanager.linux.runtime.DelegatingLinuxContainerRuntime: Unable to get cgroups handle.
      2016-03-03 16:47:58,044 DEBUG org.apache.hadoop.service.AbstractService: noteFailure org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Failed to initialize container executor
      2016-03-03 16:47:58,044 INFO org.apache.hadoop.service.AbstractService: Service NodeManager failed in state INITED; cause: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Failed to initialize container executor
      org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Failed to initialize container executor
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:240)
              at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:539)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:587)
      Caused by: java.io.IOException: Failed to initialize linux container runtime(s)!
              at org.apache.hadoop.yarn.server.nodemanager.LinuxContainerExecutor.init(LinuxContainerExecutor.java:207)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:238)
              ... 3 more
      2016-03-03 16:47:58,047 DEBUG org.apache.hadoop.service.AbstractService: Service: NodeManager entered state STOPPED
      2016-03-03 16:47:58,047 DEBUG org.apache.hadoop.service.CompositeService: NodeManager: stopping services, size=0
      2016-03-03 16:47:58,047 DEBUG org.apache.hadoop.service.AbstractService: Service: org.apache.hadoop.yarn.server.nodemanager.recovery.NMLeveldbStateStoreService entered state STOPPED
      2016-03-03 16:47:58,047 FATAL org.apache.hadoop.yarn.server.nodemanager.NodeManager: Error starting NodeManager
      org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Failed to initialize container executor
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:240)
              at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:539)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:587)
      Caused by: java.io.IOException: Failed to initialize linux container runtime(s)!
              at org.apache.hadoop.yarn.server.nodemanager.LinuxContainerExecutor.init(LinuxContainerExecutor.java:207)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:238)
              ... 3 more
      
      1. YARN-4762.001.patch
        9 kB
        Sidharta Seethana
      2. YARN-4762.002.patch
        12 kB
        Sidharta Seethana

        Issue Links

          Activity

          sidharta-s Sidharta Seethana added a comment -

          /cc Varun Vasudev

          When the new resource handler mechanism was introduced a CGroupHandlerImpl instance was only created/initialized if one of the resource handlers was enabled. Initialization does one of the following :

          1. if mounting of cgroups is enabled, does not mount anything because mounting is done on demand for individual resource handlers
          2. If mounting of cgroups is disabled, ‘initializeControllerPathsFromMtab’ gets called - which checks for writability for each of the cgroup mounts.

          (2) was correct behavior because the cgroups handler wasn’t created unless at least one of the (cgroups based) resource handlers was in use. However, with YARN-4553 , a CGroupsHandler is always created, even if there are no cgroups-based handlers in use. This (incorrectly) leads to an attempt to check if cgroups' mount paths are writable.

          I'll take a look at fixing this.

          sidharta-s Sidharta Seethana added a comment -

          Changing priority to critical - NMs don't see to come up when cgroups are not in use.

          sidharta-s Sidharta Seethana added a comment -

          Uploaded a patch with a fix ensuring that a cgroups handler is not initialized unless one or more cgroups-based resource handlers are in use.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Overall, acknowledging that the new layering is a WIP, it takes a bit of effort to wrap around the dependencies and component ordering..

          Coming to the patch, it looks good overall to me.

          One minor comment: If we can change DelegatingLinuxContainerRuntime to not know about cGroupsHandler at all, that will be good.

          Trivial issues, not related to the patch:

          • ResourceHandlerModule
            • getcGroupsCpuResourceHandler() has a typo in the case: cGroups instead of CGroups as in other methods.
            • Some modified lines in the patch overflowed 80 chars. Jenkins is likely to complain.
          • Unused import of ResourceHandlerException in DelegatingLinuxContainerRuntime
          sidharta-s Sidharta Seethana added a comment -

          Thanks for the review, Vinod Kumar Vavilapalli. Yes, I admit that some of this layering is confusing (and is a WIP) - this is because of having to maintain backward compatibility with the behavior of the existing (cgroups) resource handler.

          I'll make the changes you suggested in the patch - the typos were introduced in a different patch, but i'll fix them, nonetheless.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 13s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 34s trunk passed
          +1 compile 0m 22s trunk passed with JDK v1.8.0_74
          +1 compile 0m 26s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 15s trunk passed
          +1 mvnsite 0m 27s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 0m 50s trunk passed
          +1 javadoc 0m 16s trunk passed with JDK v1.8.0_74
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 23s the patch passed
          +1 compile 0m 20s the patch passed with JDK v1.8.0_74
          +1 javac 0m 20s the patch passed
          +1 compile 0m 24s the patch passed with JDK v1.7.0_95
          +1 javac 0m 24s the patch passed
          -1 checkstyle 0m 14s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager: patch generated 4 new + 12 unchanged - 0 fixed = 16 total (was 12)
          +1 mvnsite 0m 25s the patch passed
          +1 mvneclipse 0m 11s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 0s the patch passed
          +1 javadoc 0m 15s the patch passed with JDK v1.8.0_74
          +1 javadoc 0m 20s the patch passed with JDK v1.7.0_95
          +1 unit 9m 4s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_74.
          +1 unit 9m 35s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_95.
          +1 asflicense 0m 17s Patch does not generate ASF License warnings.
          33m 22s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12791558/YARN-4762.001.patch
          JIRA Issue YARN-4762
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux bf7a1e3550d6 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 2759689
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_74 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/10714/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager.txt
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10714/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10714/console
          Powered by Apache Yetus 0.3.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          sidharta-s Sidharta Seethana added a comment -

          Uploaded a new patch based on code review feedback. Fixed checkstyle issues.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 9s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 38s trunk passed
          +1 compile 0m 21s trunk passed with JDK v1.8.0_74
          +1 compile 0m 25s trunk passed with JDK v1.7.0_95
          +1 checkstyle 0m 16s trunk passed
          +1 mvnsite 0m 27s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 0m 48s trunk passed
          +1 javadoc 0m 17s trunk passed with JDK v1.8.0_74
          +1 javadoc 0m 21s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 23s the patch passed
          +1 compile 0m 19s the patch passed with JDK v1.8.0_74
          +1 javac 0m 19s the patch passed
          +1 compile 0m 23s the patch passed with JDK v1.7.0_95
          +1 javac 0m 23s the patch passed
          +1 checkstyle 0m 13s the patch passed
          +1 mvnsite 0m 25s the patch passed
          +1 mvneclipse 0m 10s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 59s the patch passed
          +1 javadoc 0m 15s the patch passed with JDK v1.8.0_74
          +1 javadoc 0m 19s the patch passed with JDK v1.7.0_95
          +1 unit 8m 59s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_74.
          +1 unit 9m 37s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_95.
          +1 asflicense 0m 17s Patch does not generate ASF License warnings.
          33m 11s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12791580/YARN-4762.002.patch
          JIRA Issue YARN-4762
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux b10585071dd1 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 2759689
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_74 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          findbugs v3.0.0
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10715/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/10715/console
          Powered by Apache Yetus 0.3.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          The latest patch looks good to me, +1. Checking this in.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Committed this to trunk and branch-2. Thanks Sid!

          sidharta-s Sidharta Seethana added a comment -
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9437 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9437/)
          YARN-4762. Fixed CgroupHandler's creation and usage to avoid (vinodkv: rev b2661765a5a48392a5691cee15904ed2de147b00)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/linux/runtime/DelegatingLinuxContainerRuntime.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/linux/runtime/DockerLinuxContainerRuntime.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/linux/runtime/TestDockerContainerRuntime.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/linux/resources/ResourceHandlerModule.java

            People

            • Assignee:
              sidharta-s Sidharta Seethana
              Reporter:
              vinodkv Vinod Kumar Vavilapalli
            • Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development