Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4538

QueueMetrics pending cores and memory metrics wrong

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Submit 2 application to default queue
      Check queue metrics for pending cores and memory

          List<QueueInfo> allQueues = client.getChildQueueInfos("root");
      
          for (QueueInfo queueInfo : allQueues) {
            QueueStatistics quastats = queueInfo.getQueueStatistics();
            System.out.println(quastats.getPendingVCores());
            System.out.println(quastats.getPendingMemoryMB());
          }
      
      

      Output :

      -20
      -20480

      1. 0001-YARN-4538.patch
        4 kB
        Bibin A Chundatt
      2. 0002-YARN-4538.patch
        7 kB
        Bibin A Chundatt
      3. 0003-YARN-4538.patch
        7 kB
        Bibin A Chundatt
      4. 0004-YARN-4538.patch
        7 kB
        Bibin A Chundatt
      5. 0005-YARN-4538.patch
        7 kB
        Bibin A Chundatt

        Activity

        rohithsharma Rohith Sharma K S added a comment -

        Is this same as YARN-4481?

        sunilg Sunil G added a comment -

        Hi Bibin A Chundatt
        Cud u pls upload and RM and NM logs. We are tracing issue for sometime.

        bibinchundatt Bibin A Chundatt added a comment -

        Sunil G/Rohith Sharma K S

        Thank you for looking into the issue. I am not sure its the same issue.
        Currently the issue looks like in QueueMetrics#_decrPendingResources and QueueMetrics#_incrPendingResources

          private void _decrPendingResources(int containers, Resource res) {
            // if #container = 0, means change container resource
            pendingContainers.decr(containers);
            pendingMB.decr(res.getMemory() * Math.max(containers, 1));
            pendingVCores.decr(res.getVirtualCores() * Math.max(containers, 1));
          }
        
          private void _incrPendingResources(int containers, Resource res) {
            pendingContainers.incr(containers);
            pendingMB.incr(res.getMemory() * containers);
            pendingVCores.incr(res.getVirtualCores() * containers);
          }
        

        For increase and decrease the logic looks different.

        [{Priority: 20, Capability: <memory:1024, vCores:1>, # Containers: 1, Location: *, Relax Locality: true, Node Label Expression: }]  
        [{Priority: 20, Capability: <memory:1024, vCores:1>, # Containers: 0, Location: *, Relax Locality: true, Node Label Expression: }]  
        

        The resource request in AppSchedulingInfo#updateResourceRequests is as above. And causes pendingMB and PendingVcore to be negative.
        When ever allocation request contains capacity as non zero value and container=0 the the pending resource calculation will go wrong.

        Looks related to YARN-1651.
        I will sync QueueMetrics#_incrPendingResources also same as QueueMetrics#_decrPendingResources and upload a patch soon

        Thoughts??

        leftnoteasy Wangda Tan added a comment -

        Thanks for reporting this issue, Bibin A Chundatt.

        The root cause is like what you said, _incrPendingResource and _decrPendingResource have different implementations.

        I think there're two fixes needed:

        • Add max(containers, 1) to _incrPendingResources
        • Caller of QueueMetrics#incrPendingResources/decrPendingResources should avoid calling it when #containers == 0, and it's not a decrease/increase container.

        Thoughts?

        bibinchundatt Bibin A Chundatt added a comment -

        Thanks for looking into the issue, Wangda Tan

        • Added logic to skip pending metrics update when containers<=0
        • Updating patch for the issue. Please do review
        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 8m 31s trunk passed
        +1 compile 0m 38s trunk passed with JDK v1.8.0_66
        +1 compile 0m 33s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 19s trunk passed
        +1 mvnsite 0m 43s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 1m 17s trunk passed
        +1 javadoc 0m 24s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 28s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 32s the patch passed
        +1 compile 0m 26s the patch passed with JDK v1.8.0_66
        +1 javac 0m 26s the patch passed
        +1 compile 0m 29s the patch passed with JDK v1.7.0_91
        +1 javac 0m 29s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 36s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 24s the patch passed
        +1 javadoc 0m 21s the patch passed with JDK v1.8.0_66
        +1 javadoc 0m 26s the patch passed with JDK v1.7.0_91
        -1 unit 61m 1s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
        -1 unit 62m 32s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
        +1 asflicense 0m 19s Patch does not generate ASF License warnings.
        142m 46s



        Reason Tests
        JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestAMAuthorization
          hadoop.yarn.server.resourcemanager.TestClientRMTokens
        JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestAMAuthorization
          hadoop.yarn.server.resourcemanager.TestClientRMTokens



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12780661/0001-YARN-4538.patch
        JIRA Issue YARN-4538
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux a0f5e810646a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / c52b407
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10166/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10166/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10166/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10166/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10166/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Max memory used 75MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10166/console

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        Test failures are not related to patch attached.
        All CI failures are tracked already as part of YARN-4478

        leftnoteasy Wangda Tan added a comment -

        Hi Bibin A Chundatt,
        Thanks for working on the patch, looked at your patch, I think this patch may break some existing scenario, let me explain:

        For existing workflow:

        • Container increase/decrease: call incr/decrPendingResource of QueueMetrics, Parameter is: #container=0, resource=delta-resource. And incr/decrPendingResource should not change #container, but should update pendingResource by resource
        • Container allocation/release: call incr/decrPendingResource of QueueMetrics, Parameter is: #container should > 0, resource=per-container-resource, pendingResource should be updated by #container * resource

        So under this assumption, when container increase/decrease, your existing patch will skip updating pendingResource.

        Suggestion of fixes:

        • Choice#1, change all existing caller of incr/decrPendingResource for container allocation/release to make sure that they will be called when #container>0
        • Choice#2, create a new method for increase/decrease container to change resource but not update #container in QueueMetrics.

        I would prefer choice#2.

        Thoughts?

        bibinchundatt Bibin A Chundatt added a comment -

        Hi Wangda Tan

        Thank you for looking in to the patch.

        • Missed pendingResource by resource update for Container increase/decrease.
        • Updated patch for the same based on Choice#2

        Please do review

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 40s trunk passed
        +1 compile 0m 28s trunk passed with JDK v1.8.0_66
        +1 compile 0m 31s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 36s trunk passed
        +1 mvneclipse 0m 16s trunk passed
        +1 findbugs 1m 13s trunk passed
        +1 javadoc 0m 22s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 28s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 32s the patch passed
        +1 compile 0m 24s the patch passed with JDK v1.8.0_66
        +1 javac 0m 24s the patch passed
        +1 compile 0m 28s the patch passed with JDK v1.7.0_91
        +1 javac 0m 28s the patch passed
        -1 checkstyle 0m 13s Patch generated 2 new checkstyle issues in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager (total was 77, now 78).
        +1 mvnsite 0m 34s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 16s the patch passed
        +1 javadoc 0m 19s the patch passed with JDK v1.8.0_66
        +1 javadoc 0m 25s the patch passed with JDK v1.7.0_91
        +1 unit 63m 53s hadoop-yarn-server-resourcemanager in the patch passed with JDK v1.8.0_66.
        +1 unit 65m 43s hadoop-yarn-server-resourcemanager in the patch passed with JDK v1.7.0_91.
        +1 asflicense 0m 18s Patch does not generate ASF License warnings.
        147m 13s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12780903/0002-YARN-4538.patch
        JIRA Issue YARN-4538
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 0e4e954ba8ba 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 2b25284
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/10182/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10182/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Max memory used 75MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10182/console

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        Attaching patch after checkstyle fix

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 32s trunk passed
        +1 compile 0m 26s trunk passed with JDK v1.8.0_66
        +1 compile 0m 30s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 36s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 1m 14s trunk passed
        +1 javadoc 0m 21s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 27s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 30s the patch passed
        +1 compile 0m 22s the patch passed with JDK v1.8.0_66
        +1 javac 0m 22s the patch passed
        +1 compile 0m 27s the patch passed with JDK v1.7.0_91
        +1 javac 0m 27s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 33s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 16s the patch passed
        +1 javadoc 0m 18s the patch passed with JDK v1.8.0_66
        +1 javadoc 0m 24s the patch passed with JDK v1.7.0_91
        +1 unit 59m 8s hadoop-yarn-server-resourcemanager in the patch passed with JDK v1.8.0_66.
        +1 unit 60m 1s hadoop-yarn-server-resourcemanager in the patch passed with JDK v1.7.0_91.
        +1 asflicense 0m 16s Patch does not generate ASF License warnings.
        136m 19s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12780971/0003-YARN-4538.patch
        JIRA Issue YARN-4538
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 427fd2be551b 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6702e7d
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10189/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Max memory used 76MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10189/console

        This message was automatically generated.

        bibinchundatt Bibin A Chundatt added a comment -

        Test case failures are not related to patch uploaded . Please review patch

        leftnoteasy Wangda Tan added a comment -

        Thanks for updating, Bibin A Chundatt,

        Patch generally looks good, one minor comment is:

          public void allocateResources(String user, Resource res,
              boolean decrPending)
        

        The 3rd boolean parameter is not needed. Nobody is using it now.

        bibinchundatt Bibin A Chundatt added a comment -

        Attaching updated patch

        bibinchundatt Bibin A Chundatt added a comment -

        Wangda Tan
        Thank you for review . Attached patch based on review comment

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 36s trunk passed
        +1 compile 0m 28s trunk passed with JDK v1.8.0_66
        +1 compile 0m 31s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 38s trunk passed
        +1 mvneclipse 0m 16s trunk passed
        +1 findbugs 1m 13s trunk passed
        +1 javadoc 0m 22s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 27s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 32s the patch passed
        +1 compile 0m 24s the patch passed with JDK v1.8.0_66
        +1 javac 0m 24s the patch passed
        +1 compile 0m 29s the patch passed with JDK v1.7.0_91
        +1 javac 0m 29s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 34s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 17s the patch passed
        -1 javadoc 0m 20s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
        -1 javadoc 2m 34s hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91 with JDK v1.7.0_91 generated 1 new issues (was 2, now 3).
        +1 javadoc 0m 25s the patch passed with JDK v1.7.0_91
        -1 unit 64m 17s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
        -1 unit 65m 26s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
        +1 asflicense 0m 17s Patch does not generate ASF License warnings.
        147m 22s



        Reason Tests
        JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
          hadoop.yarn.server.resourcemanager.TestAMAuthorization
        JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestClientRMTokens
          hadoop.yarn.server.resourcemanager.TestAMAuthorization
          hadoop.yarn.server.resourcemanager.scheduler.fair.TestFairScheduler



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12782244/0004-YARN-4538.patch
        JIRA Issue YARN-4538
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e51b52eb2df8 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 3ddb92b
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        javadoc https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/patch-javadoc-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
        javadoc hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91: https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/diff-javadoc-javadoc-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10279/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10279/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Max memory used 76MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10279/console

        This message was automatically generated.

        leftnoteasy Wangda Tan added a comment -

        +1 to latest patch, Bibin A Chundatt, could you take a look at javadocs warning?

        bibinchundatt Bibin A Chundatt added a comment -

        Wangda Tan
        Thanks for review .
        Sorry to miss javadoc. Patch uploaded correcting javadoc.
        Please do review.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 34s trunk passed
        +1 compile 0m 25s trunk passed with JDK v1.8.0_66
        +1 compile 0m 31s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 13s trunk passed
        +1 mvnsite 0m 36s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 10s trunk passed
        +1 javadoc 0m 20s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 26s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 31s the patch passed
        +1 compile 0m 23s the patch passed with JDK v1.8.0_66
        +1 javac 0m 23s the patch passed
        +1 compile 0m 27s the patch passed with JDK v1.7.0_91
        +1 javac 0m 27s the patch passed
        +1 checkstyle 0m 13s the patch passed
        +1 mvnsite 0m 33s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 14s the patch passed
        +1 javadoc 0m 18s the patch passed with JDK v1.8.0_66
        +1 javadoc 0m 24s the patch passed with JDK v1.7.0_91
        -1 unit 59m 36s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.8.0_66.
        -1 unit 61m 0s hadoop-yarn-server-resourcemanager in the patch failed with JDK v1.7.0_91.
        +1 asflicense 0m 23s Patch does not generate ASF License warnings.
        137m 50s



        Reason Tests
        JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.resourcemanager.TestAMAuthorization
          hadoop.yarn.server.resourcemanager.TestClientRMTokens
        JDK v1.7.0_91 Failed junit tests hadoop.yarn.server.resourcemanager.TestAMAuthorization
          hadoop.yarn.server.resourcemanager.webapp.TestRMWebServicesDelegationTokens
          hadoop.yarn.server.resourcemanager.TestClientRMTokens



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12782452/0005-YARN-4538.patch
        JIRA Issue YARN-4538
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 3361cf8a0d7f 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 1da762c
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10297/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10297/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10297/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10297/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-resourcemanager-jdk1.7.0_91.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10297/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager
        Max memory used 76MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10297/console

        This message was automatically generated.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9129 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9129/)
        YARN-4538. QueueMetrics pending cores and memory metrics wrong. (Bibin A (wangda: rev 9523648d57ebc71cf5c57f3f8c52c4a63265b61c)

        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/scheduler/QueueMetrics.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/scheduler/TestQueueMetrics.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/scheduler/AppSchedulingInfo.java
        leftnoteasy Wangda Tan added a comment -

        Committed to trunk/branch-2/branch-2.8, thanks Bibin A Chundatt and reviews from Rohith Sharma K S/Sunil G.

        bibinchundatt Bibin A Chundatt added a comment -

        Thank you Rohith Sharma K S,Sunil G , Wangda Tan for review and commit


          People

          • Assignee:
            bibinchundatt Bibin A Chundatt
            Reporter:
            bibinchundatt Bibin A Chundatt
          • Votes:
            0 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development