Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha2
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Currently it can be only launched outside of YARN, we should make it runnable inside YARN for easier testing and we should have a configuration to enable/disable it.

      1. YARN-4515-YARN-3368.7.patch
        58 kB
        Sunil G
      2. YARN-4515-YARN-3368.6.patch
        56 kB
        Sunil G
      3. YARN-4515-YARN-3368.5.patch
        59 kB
        Sunil G
      4. YARN-4515-YARN-3368.4.patch
        57 kB
        Sunil G
      5. YARN-4515-YARN-3368.3.patch
        54 kB
        Sunil G
      6. YARN-4515-YARN-3368.2.patch
        53 kB
        Sunil G
      7. YARN-4515-YARN-3368.1.patch
        50 kB
        Sunil G
      8. 0001-YARN-4515.patch
        24 kB
        Sunil G
      9. preliminary-YARN-4515-host_rm_web_ui_v2.patch
        4 kB
        Wangda Tan

        Activity

        sunilg Sunil G added a comment -

        Hi Wangda Tan
        I will try taking this ticket. Pls let me know if its fine.

        leftnoteasy Wangda Tan added a comment -

        Sure! Please go ahead.

        Thanks,

        leftnoteasy Wangda Tan added a comment -

        Spent some time on this today, trying to host webapps inside RM (using HttpServer2).

        After apply the patch:

        • Run mvn -DskipTests install -Pyarn-ui to compile ui-related code.
        • Copy hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/hadoop-yarn-ui-3.0.0-SNAPSHOT/* to $HADOOP_HOME/share/hadoop/yarn/webapps/rm/
        • Start RM, the HTTP port is localhost:8888.

        Go to localhost:8888, page can be rendered (cluster metrics), however, I cannot go to other pages such as apps/queues, 404 error is reported. I think there maybe some relative path configs need to be updated.

        Sunil G, could you take a look at this issue if you have bandwidth recently? Thanks!

        sunilg Sunil G added a comment -

        Thanks Wangda Tan. This is really helpful.
        I will help in bringing remaining changes now.

        sunilg Sunil G added a comment -

        Attaching an updated patch with changes from UI end also

        Things handled:

        • All pages can be accessed now via a deployed UI2 under httpserver2.
        • Configuration supported is added to choose web port.
        • Used "#" as prefix for all hyper references. For external URLs, this is needed. For internal routes, used link-to. I could not use link-to for some more route redirection as it has more input params. I will try fix that also if possible.

        Things to notice (or not handled in this patch)

        • Maven support to package the compiled UI2 war and put it under $share/hadoop/yarn/rm. I will update this in next patch. Pls use steps mentioned by Wangda Tan for now.
        • When there are no apps/nodes available, few error message is shown under the table as a row. This will cause a warning. So i have not shown the whole table, and just shown a message. PLs suggest some other alternatives if you feel.

        Wangda Tan/Varun Saxena. pls help to check the same.

        sunilg Sunil G added a comment -

        Missed one point.

        • locationType is still used auto. If we want to use browser back button, then hash needs to be used to replace the history. But if we changes to hash, then it wont work with "ember serve" command. We need a new template for development and set that as auto. For public release, use hash like tez UI.
        leftnoteasy Wangda Tan added a comment -

        Some issues when I tried to run with the patch:

        What I have done:

        • I copied js/html to webapps/rm
        • Modified webapps/rm/config/configs.env to make sure localBaseAddress: "localhost:1337"
        • Start RM in local host
        • Run corsproxy
        • Go to localhost:8288

        It shows error:

        XMLHttpRequest cannot load http://localhost:1337/localhost:8088/ws/v1/cluster/metrics. The 'Access-Control-Allow-Origin' header contains multiple values 'http://evil.com/, *', but only one is allowed. Origin 'http://localhost:8288' is therefore not allowed access.
        vendor-f2b8b19….js:11 Error: Adapter operation failed
            at new Error (native)
            at Error.n (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:8:4037)
            at Error.e (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:2065)
            at n.handleResponse (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:22139)
            at n.c.error (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:22648)
            at c (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:2:6024)
            at Object.fireWith [as rejectWith] (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:2:6836)
            at n (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:3:11508)
            at XMLHttpRequest.<anonymous> (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:3:17202)
        

        And if I set localBaseAddress to empty, and stop corsproxy, on localhost:8288, it shows:

        XMLHttpRequest cannot load http://localhost:8088/ws/v1/cluster/metrics. A wildcard '*' cannot be used in the 'Access-Control-Allow-Origin' header when the credentials flag is true. Origin 'http://localhost:8288' is therefore not allowed access. The credentials mode of an XMLHttpRequest is controlled by the withCredentials attribute.
        vendor-f2b8b19….js:11 Error: Adapter operation failed
            at new Error (native)
            at Error.n (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:8:4037)
            at Error.e (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:2065)
            at n.handleResponse (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:22139)
            at n.c.error (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:30:22648)
            at c (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:2:6024)
            at Object.fireWith [as rejectWith] (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:2:6836)
            at n (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:3:11508)
            at XMLHttpRequest.<anonymous> (http://localhost:8288/assets/vendor-f2b8b19533691ddb57f3926c35c36bf2.js:3:17202)
        

        And a couple of quick comments:
        1. Could we add a config to start yarn-ui-v2 on demand? (disable it by default)
        2. LOG.error("Failed to start Yarn web app v2") should not swallow exception

        leftnoteasy Wangda Tan added a comment -

        BTW: do I need to apply other patches to try this?

        leftnoteasy Wangda Tan added a comment -

        My bad, it is caused by one Chrome plugin I installed: Allow-Control-Allow-Origin: *. After disable the plugin and set localBaseAddress: "localhost:1337", it works for me.

        Refresh page and back page seems wrong, which should be addressed by your last comment (auto/hash stuffs).

        sunilg Sunil G added a comment -

        A combined patch with YARN-5000. This will help to test UI overall. But I found that its not rebased to latest branch (YARN-5019 url hyphen fix). I will now work on rebasing the same.
        Wangda Tan, pls help to check the same w/o YARN-5019 to test the same immediately. I will upload a clean patch in some hours.

        sunilg Sunil G added a comment -

        Uploading a rebased patch. This is still combined with YARN-5000 for easiness in testing. Will attach an independent patch after a round of test/review.

        sunilg Sunil G added a comment -

        Uploading a cleaner patch.
        Wangda Tan, could you please help to check the same. I have not handled YARN-5038 here. It seems that YARN-5038 requires some more discussions. Pls help to check this patch and kindly share your thoughts.

        sunilg Sunil G added a comment -

        Issues mentioned in YARN-5038 is also handled in this latest patch. This now has fix of YARN-5000, YARN-5038 and YARN-4515. I will mark YARN-5038 as duplicate. Wangda Tan, kindly help to check the same and pls share your feedback.

        leftnoteasy Wangda Tan added a comment -

        Thanks Sunil G!

        Refresh/back works perfectly for me!

        Few issues:

        • I still see finish time is 1969.xx on applications table and application page.
        • Node web UI link in container page (when click container in application attempt page) doesn't work.
        sunilg Sunil G added a comment -

        Thank you Wangda Tan for the comments.

        • Fixed the finished time issue in app and apps page.
        • app-attempt page link will work when app is running or finished. But if app page is loaded when app is running, and the app-attempt link is clicked only after app s finished , then i could see the link is not transitioning to app-attempt. If app page is refreshed, then the link works fine. I will investigate in detail mostly in another ticket. Pls suggest if this is fine.
        • mvn package will also pack web-ui to $HADOOP_HOME/share/hadoop/yarn/webapps/rm. So with below configuration, we can launch web ui2 within yarn.
          <property>
            <name>yarn.resourcemanager.webapp.ui2.enable</name>
            <value>true</value>
          </property>
          <property>
            <name>yarn.resourcemanager.webapp.ui2.address</name>
            <value>127.0.0.1:8288</value>
          </property>
        
        
        sunilg Sunil G added a comment -

        Missed one comment from Wangda Tan earlier.
        Node UI link will now work from container table (app-attempt page). Wangda Tan, kindly help to check the new patch.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 1m 47s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        0 mvndep 3m 19s Maven dependency ordering for branch
        +1 mvninstall 7m 55s YARN-3368 passed
        +1 compile 7m 50s YARN-3368 passed with JDK v1.8.0_91
        +1 compile 7m 6s YARN-3368 passed with JDK v1.7.0_101
        +1 checkstyle 1m 32s YARN-3368 passed
        +1 mvnsite 9m 52s YARN-3368 passed
        +1 mvneclipse 1m 39s YARN-3368 passed
        0 findbugs 0m 0s Skipped branch modules with no Java source: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui .
        +1 findbugs 2m 22s YARN-3368 passed
        +1 javadoc 5m 23s YARN-3368 passed with JDK v1.8.0_91
        +1 javadoc 9m 33s YARN-3368 passed with JDK v1.7.0_101
        0 mvndep 0m 15s Maven dependency ordering for patch
        +1 mvninstall 8m 26s the patch passed
        +1 compile 8m 7s the patch passed with JDK v1.8.0_91
        +1 javac 8m 7s the patch passed
        +1 compile 6m 42s the patch passed with JDK v1.7.0_101
        +1 javac 6m 42s the patch passed
        -1 checkstyle 1m 30s root: patch generated 3 new + 264 unchanged - 0 fixed = 267 total (was 264)
        +1 mvnsite 8m 52s the patch passed
        +1 mvneclipse 0m 39s the patch passed
        -1 whitespace 0m 0s The patch has 3 line(s) with tabs.
        +1 xml 0m 0s The patch has no ill-formed XML file.
        0 findbugs 0m 0s Skipped patch modules with no Java source: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui .
        +1 findbugs 2m 46s the patch passed
        +1 javadoc 5m 19s the patch passed with JDK v1.8.0_91
        +1 javadoc 9m 36s the patch passed with JDK v1.7.0_101
        -1 unit 36m 12s root in the patch failed with JDK v1.8.0_91.
        -1 unit 105m 55s root in the patch failed with JDK v1.7.0_101.
        -1 asflicense 0m 25s Patch generated 1 ASF License warnings.
        254m 29s



        Reason Tests
        JDK v1.8.0_91 Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle
        JDK v1.7.0_101 Failed junit tests hadoop.hdfs.server.datanode.TestDataNodeUUID
          hadoop.yarn.conf.TestYarnConfigurationFields



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:6984808
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12803997/YARN-4515-YARN-3368.6.patch
        JIRA Issue YARN-4515
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
        uname Linux 3aea94d576a7 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision YARN-3368 / 117ef9e
        Default Java 1.7.0_101
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_91 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_101
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/diff-checkstyle-root.txt
        whitespace https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/whitespace-tabs.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/patch-unit-root-jdk1.8.0_91.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/patch-unit-root-jdk1.7.0_101.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/patch-unit-root-jdk1.8.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/patch-unit-root-jdk1.7.0_101.txt
        JDK v1.7.0_101 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/11462/testReport/
        asflicense https://builds.apache.org/job/PreCommit-YARN-Build/11462/artifact/patchprocess/patch-asflicense-problems.txt
        modules C: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui hadoop-yarn-project/hadoop-yarn/hadoop-yarn-api hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager . U: .
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/11462/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        sunilg Sunil G added a comment -

        Fixed test case failures and asf license warnings.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 11s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        0 mvndep 0m 14s Maven dependency ordering for branch
        +1 mvninstall 6m 33s YARN-3368 passed
        +1 compile 5m 43s YARN-3368 passed with JDK v1.8.0_91
        +1 compile 6m 40s YARN-3368 passed with JDK v1.7.0_101
        +1 checkstyle 1m 26s YARN-3368 passed
        +1 mvnsite 8m 55s YARN-3368 passed
        +1 mvneclipse 0m 39s YARN-3368 passed
        0 findbugs 0m 0s Skipped branch modules with no Java source: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui .
        -1 findbugs 1m 8s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common in YARN-3368 has 1 extant Findbugs warnings.
        +1 javadoc 5m 20s YARN-3368 passed with JDK v1.8.0_91
        +1 javadoc 9m 27s YARN-3368 passed with JDK v1.7.0_101
        0 mvndep 0m 14s Maven dependency ordering for patch
        +1 mvninstall 8m 17s the patch passed
        +1 compile 5m 46s the patch passed with JDK v1.8.0_91
        +1 javac 5m 46s the patch passed
        +1 compile 6m 39s the patch passed with JDK v1.7.0_101
        +1 javac 6m 39s the patch passed
        +1 checkstyle 1m 28s the patch passed
        +1 mvnsite 8m 59s the patch passed
        +1 mvneclipse 0m 39s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 xml 0m 1s The patch has no ill-formed XML file.
        0 findbugs 0m 0s Skipped patch modules with no Java source: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui .
        +1 findbugs 4m 5s the patch passed
        +1 javadoc 5m 19s the patch passed with JDK v1.8.0_91
        +1 javadoc 9m 31s the patch passed with JDK v1.7.0_101
        -1 unit 37m 30s root in the patch failed with JDK v1.8.0_91.
        -1 unit 120m 43s root in the patch failed with JDK v1.7.0_101.
        +1 asflicense 0m 25s Patch does not generate ASF License warnings.
        259m 51s



        Reason Tests
        JDK v1.8.0_91 Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle
        JDK v1.7.0_101 Failed junit tests hadoop.hdfs.server.datanode.fsdataset.impl.TestFsDatasetImpl



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:6984808
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12804024/YARN-4515-YARN-3368.7.patch
        JIRA Issue YARN-4515
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
        uname Linux 377aab23b1c0 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision YARN-3368 / 117ef9e
        Default Java 1.7.0_101
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_91 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_101
        findbugs v3.0.0
        findbugs https://builds.apache.org/job/PreCommit-YARN-Build/11466/artifact/patchprocess/branch-findbugs-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-common-warnings.html
        unit https://builds.apache.org/job/PreCommit-YARN-Build/11466/artifact/patchprocess/patch-unit-root-jdk1.8.0_91.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/11466/artifact/patchprocess/patch-unit-root-jdk1.7.0_101.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/11466/artifact/patchprocess/patch-unit-root-jdk1.8.0_91.txt https://builds.apache.org/job/PreCommit-YARN-Build/11466/artifact/patchprocess/patch-unit-root-jdk1.7.0_101.txt
        JDK v1.7.0_101 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/11466/testReport/
        modules C: hadoop-assemblies hadoop-assemblies hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui hadoop-yarn-project/hadoop-yarn/hadoop-yarn-api hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager . U: .
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/11466/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        sunilg Sunil G added a comment -

        Findbugs warnings are not caused by this patch. Also test cases failures are unrelated.

        leftnoteasy Wangda Tan added a comment -

        Thanks Sunil G, latest patch looks good to me, committing.

        leftnoteasy Wangda Tan added a comment -

        Local verified the patch, made minor updates to the patch (update pom.xml in yarn-ui project from 3.0.0-SNAPSHOT to 3.0.0-alpha1-SNAPSHOT) and committed to branch, thanks Sunil G for this fix.

        sunilg Sunil G added a comment -

        Thanks Wangda Tan for updating the patch and thanks for the review and commit!

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10778 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10778/)
        YARN-4515. YARN-3368 Support hosting web UI framework inside YARN RM. (wangda: rev c85cc3b56ebc63010fb22eb1bfa5849d591f4bcc)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/pom.xml
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/adapters/yarn-node-container.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/config/environment.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/helpers/log-files-comma.js
        • (add) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/components/node-menu-panel.hbs
        • (edit) LICENSE.txt
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/components/app-table.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-app.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/error.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/package.json
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/adapters/yarn-container-log.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-node-container.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/components/tree-selector.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-apps.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/routes/yarn-app-attempt.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-node-app.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-node-container.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/components/timeline-view.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/resources/yarn-default.xml
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-app.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/helpers/node-menu.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-nodes.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/helpers/node-link.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-app-attempt.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-api/src/main/java/org/apache/hadoop/yarn/conf/YarnConfiguration.java
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-node.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/adapters/yarn-node-app.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-node-app.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-node-apps.hbs
        • (add) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/helpers/node-name.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/components/container-table.hbs
        • (add) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/tests/unit/helpers/node-name-test.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/components/app-attempt-table.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/components/timeline-view.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/adapters/yarn-app-attempt.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-app-attempt.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-queue.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/models/yarn-app-attempt.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/models/yarn-app.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-rm-node.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/adapters/yarn-node.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/serializers/yarn-container.js
        • (edit) hadoop-assemblies/src/main/resources/assemblies/hadoop-yarn-dist.xml
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/models/yarn-container.js
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/yarn-node-containers.hbs
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/src/main/webapp/app/templates/application.hbs

          People

          • Assignee:
            sunilg Sunil G
            Reporter:
            leftnoteasy Wangda Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development