Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4408

NodeManager still reports negative running containers

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: nodemanager
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      YARN-1697 fixed a problem where the NodeManager metrics could report a negative number of running containers. However, it missed a rare case where this can still happen.

      YARN-1697 added a flag to indicate if the container was actually launched (LOCALIZED to RUNNING) or not (LOCALIZED to KILLING), which is then checked when transitioning from CONTAINER_CLEANEDUP_AFTER_KILL to DONE and EXITED_WITH_FAILURE to DONE to only decrement the gauge if we actually ran the container and incremented the gauge . However, this flag is not checked while transitioning from EXITED_WITH_SUCCESS to DONE.

      1. YARN-4408.001.patch
        5 kB
        Robert Kanter
      2. YARN-4408.002.patch
        5 kB
        Robert Kanter
      3. YARN-4408.003.patch
        5 kB
        Robert Kanter

        Issue Links

          Activity

          rkanter Robert Kanter added a comment -

          The patch adds the missing check. It also adds a unit test for this case, and for one of the other cases, which was missing.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 8m 5s trunk passed
          +1 compile 0m 28s trunk passed with JDK v1.8.0_66
          +1 compile 0m 30s trunk passed with JDK v1.7.0_85
          +1 checkstyle 0m 11s trunk passed
          +1 mvnsite 0m 30s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 1m 1s trunk passed
          +1 javadoc 0m 20s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_85
          +1 mvninstall 0m 29s the patch passed
          +1 compile 0m 26s the patch passed with JDK v1.8.0_66
          +1 javac 0m 26s the patch passed
          +1 compile 0m 29s the patch passed with JDK v1.7.0_85
          +1 javac 0m 29s the patch passed
          +1 checkstyle 0m 12s the patch passed
          +1 mvnsite 0m 30s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 10s the patch passed
          +1 javadoc 0m 19s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 23s the patch passed with JDK v1.7.0_85
          +1 unit 8m 45s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_66.
          +1 unit 9m 14s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_85.
          +1 asflicense 0m 23s Patch does not generate ASF License warnings.
          35m 18s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12775166/YARN-4408.001.patch
          JIRA Issue YARN-4408
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 508e15da309c 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 3c4a34e
          findbugs v3.0.0
          JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/9831/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/9831/console

          This message was automatically generated.

          djp Junping Du added a comment -

          Robert Kanter, do we see this happen in a real deployment? I don't quite understand how it happens for container not get launched but EXITED_WITH_SUCCESS. It sounds only theoretically possible for containers in life cycle: Localized -> Killing -> EXITED_WITH_SUCCESS as the only place that send CONTAINER_EXITED_WITH_SUCCESS event is ContainerLaunch (or RecoveredContainerLaunch). Isn't it? Do I miss something here?

          rkanter Robert Kanter added a comment -

          I haven't been able to reproduce this issue, and I agree that it's not a common occurrence; but we have seen the number of running containers go negative internally on two different clusters and also on a customer's cluster. So I started through the code and state machine for how we could decrement the gauge without first incrementing it. As far as I can tell, this is the only way where this can happen because we don't check container.wasLaunched like in the other two places where we decrement the gauge.

          djp Junping Du added a comment -

          Thanks Robert for reply. If we don't understand how it happens in the short term, shall we add a warn log message if container get finished with success but not get launched before? I think that could be helpful for our debug in future or this fix could cover something unusual we were missing. Others looks fine to me.

          rkanter Robert Kanter added a comment -

          The 002 patch adds the debug message.

          djp Junping Du added a comment -

          Thanks Robert for updating the patch. Can we make log messages here in WARN level given this is unusual case and our log level is only enabled for INFO or above by default?

          rkanter Robert Kanter added a comment -

          Sure. The 003 patch uses warn level.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 8m 23s trunk passed
          +1 compile 0m 32s trunk passed with JDK v1.8.0_66
          +1 compile 0m 29s trunk passed with JDK v1.7.0_85
          +1 checkstyle 0m 12s trunk passed
          +1 mvnsite 0m 31s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 1m 3s trunk passed
          +1 javadoc 0m 21s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 22s trunk passed with JDK v1.7.0_85
          +1 mvninstall 0m 28s the patch passed
          +1 compile 0m 28s the patch passed with JDK v1.8.0_66
          +1 javac 0m 28s the patch passed
          +1 compile 0m 29s the patch passed with JDK v1.7.0_85
          +1 javac 0m 29s the patch passed
          +1 checkstyle 0m 10s the patch passed
          +1 mvnsite 0m 30s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 9s the patch passed
          +1 javadoc 0m 20s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 22s the patch passed with JDK v1.7.0_85
          +1 unit 8m 54s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.8.0_66.
          +1 unit 9m 16s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_85.
          +1 asflicense 0m 25s Patch does not generate ASF License warnings.
          35m 57s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12775359/YARN-4408.002.patch
          JIRA Issue YARN-4408
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 98a4b6fe7980 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 6b9a5be
          findbugs v3.0.0
          JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/9843/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/9843/console

          This message was automatically generated.

          djp Junping Du added a comment -

          +1 on 003 patch. Will commit it shortly if no further comments from others.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 10m 43s trunk passed
          +1 compile 0m 39s trunk passed with JDK v1.8.0_66
          +1 compile 0m 37s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 15s trunk passed
          +1 mvnsite 0m 38s trunk passed
          +1 mvneclipse 0m 17s trunk passed
          +1 findbugs 1m 15s trunk passed
          +1 javadoc 0m 29s trunk passed with JDK v1.8.0_66
          +1 javadoc 0m 29s trunk passed with JDK v1.7.0_91
          +1 mvninstall 0m 36s the patch passed
          +1 compile 0m 41s the patch passed with JDK v1.8.0_66
          +1 javac 0m 41s the patch passed
          +1 compile 0m 36s the patch passed with JDK v1.7.0_91
          +1 javac 0m 36s the patch passed
          +1 checkstyle 0m 14s the patch passed
          +1 mvnsite 0m 38s the patch passed
          +1 mvneclipse 0m 16s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 26s the patch passed
          +1 javadoc 0m 31s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 30s the patch passed with JDK v1.7.0_91
          -1 unit 10m 33s hadoop-yarn-server-nodemanager in the patch failed with JDK v1.8.0_66.
          +1 unit 10m 16s hadoop-yarn-server-nodemanager in the patch passed with JDK v1.7.0_91.
          +1 asflicense 0m 29s Patch does not generate ASF License warnings.
          43m 39s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.yarn.server.nodemanager.containermanager.localizer.TestResourceLocalizationService



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12775371/YARN-4408.003.patch
          JIRA Issue YARN-4408
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux a706d5bbec00 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 6b9a5be
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-YARN-Build/9844/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_66.txt
          unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/9844/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-jdk1.8.0_66.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/9844/testReport/
          modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/9844/console

          This message was automatically generated.

          rkanter Robert Kanter added a comment -

          Test failure looks unrelated.

          djp Junping Du added a comment -

          +1. The test failure is not related and already tracked in YARN-4393. Committing this in.

          djp Junping Du added a comment -

          I have commit 03 patch to trunk, branch-2 and branch-2.8. Thanks Robert Kanter for the contribution!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8913 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8913/)
          YARN-4408. Fix issue that NodeManager still reports negative running (junping_du: rev 62e9348bc10bb97a5fcb4281f7996a09d8e69c60)

          • hadoop-yarn-project/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/container/TestContainer.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/container/ContainerImpl.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #661 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/661/)
          YARN-4408. Fix issue that NodeManager still reports negative running (junping_du: rev 62e9348bc10bb97a5fcb4281f7996a09d8e69c60)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/container/ContainerImpl.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/container/TestContainer.java
          • hadoop-yarn-project/CHANGES.txt
          rkanter Robert Kanter added a comment -

          Thanks Junping Du!


            People

            • Assignee:
              rkanter Robert Kanter
              Reporter:
              rkanter Robert Kanter
            • Votes:
              0 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development