Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-3292

[Umbrella] Tests/documentation and/or tools for YARN rolling upgrades backwards/forward compatibility verification

Add voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

      Description

      YARN-666 added the support to YARN rolling upgrade. In order to support this feature, we made changes from many perspectives. There were many assumptions made together with these existing changes. Future code changes may break these assumptions by accident, and hence break the YARN rolling upgrades feature.

      To simplify YARN RU regression tests, maybe we would like to create a set of tools/tests that can verify YARN RU backward compatibility.

      On the very first step, we may want to have a compatibility checker for important protocols and APIs. We may also want to incorporate these tools into our test Jenkins runs, if necessary.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              gtcarrera9 Li Lu
              Reporter:
              gtcarrera9 Li Lu

              Dates

              • Created:
                Updated:

                Issue deployment