Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-3254

HealthReport should include disk full information

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0
    • Fix Version/s: 2.9.0, 3.0.0-beta1
    • Component/s: nodemanager
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When a NodeManager's local disk gets almost full, the NodeManager sends a health report to ResourceManager that "local/log dir is bad" and the message is displayed on ResourceManager Web UI. It's difficult for users to detect why the dir is bad.

      1. Screen Shot 2015-02-24 at 17.57.39.png
        97 kB
        Akira Ajisaka
      2. Screen Shot 2015-02-25 at 14.38.10.png
        113 kB
        Akira Ajisaka
      3. YARN-3254-001.patch
        9 kB
        Akira Ajisaka
      4. YARN-3254-002.patch
        9 kB
        Akira Ajisaka
      5. YARN-3254-003.patch
        8 kB
        Suma Shivaprasad
      6. YARN-3254-004.patch
        9 kB
        Suma Shivaprasad
      7. YARN-3254-005.patch
        13 kB
        Suma Shivaprasad
      8. YARN-3254-006.patch
        14 kB
        Suma Shivaprasad

        Activity

        ajisakaa Akira Ajisaka added a comment -

        Attaching a screenshot when the NodeManager's disk is almost full.

        ajisakaa Akira Ajisaka added a comment -

        Attaching a patch to add a new public method getDisksHealthReport(boolean, boolean), and deprecate the existing method getDisksHealthReport(boolean) for backward compatibility. I'll attach a screen shot later.

        ajisakaa Akira Ajisaka added a comment -

        v2 patch fixes log formatting.

        hadoopqa Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12700863/YARN-3254-001.patch
        against trunk revision 5731c0e.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager.

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/6741//testReport/
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/6741//console

        This message is automatically generated.

        ajisakaa Akira Ajisaka added a comment -

        Attaching a screenshot after applying v2 patch.

        hadoopqa Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12700871/YARN-3254-002.patch
        against trunk revision caa42ad.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager.

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/6742//testReport/
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/6742//console

        This message is automatically generated.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12700883/Screen%20Shot%202015-02-25%20at%2014.38.10.png
        against trunk revision caa42ad.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/6745//console

        This message is automatically generated.

        ajisakaa Akira Ajisaka added a comment -

        I reconsidered that, after all the issue is not a problem because

        • Admin can read NodeManager's log and find the message as follows:
          2015-02-26 07:34:22,485 WARN org.apache.hadoop.yarn.server.nodemanager.Directory
          Collection: Directory /usr/local/20150225-YARN-3254-2/logs/userlogs error, used 
          space above threshold of 90.0%, removing from list of valid directories
          
        • This patch is still incompatible as jmx information is actually changed.
        ajisakaa Akira Ajisaka added a comment -

        Closing. If someone really wants to fix this, please reopen this.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Akira Ajisaka Although the Nodemanager's log shows the reason for directories being unhealthy, it would be useful to have the NodeManager's UI health report display if the directories have errors/are full. Would you mind if I take over this JIRA if you are not working on this currently ? Also, can you please explain why the patch is incompatible with jmx information being changed ?

        ajisakaa Akira Ajisaka added a comment -

        Would you mind if I take over this JIRA if you are not working on this currently ?

        No. You can take it over.

        Also, can you please explain why the patch is incompatible with jmx information being changed ?

        This health report is obtained from jmx. Accoding to the documentation (https://hadoop.apache.org/docs/current/hadoop-project-dist/hadoop-common/Compatibility.html#MetricsJMX), changing the jmx information breaks compatibility. Now I'm thinking you can add the message to the Web UI if you create an additional jmx information and use it.

        leftnoteasy Wangda Tan added a comment -

        Akira Ajisaka,

        I think the original definition of JMX metrics compatibility is overkill, I can understand the "semantic consistency" part, for example, change unit (from GB to MB, etc.). For text fields such as report, we should be able to change them if needed.

        For example, YARN-90/YARN-6302 have already changed report field, if we strictly follow the rule, we probably need to revert these patches as well.

        I would prefer to continue improving the text field. And start discussion to modify the compatibility rule.

        cc: Karthik Kambatla (original author of the compatibility doc) and Daniel Templeton.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Attached a patch which bifurcates disks health failure reports into failed vs errored disks, which is already available as part of existing disk health checks

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 18s Docker mode activated.
              Prechecks
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
              trunk Compile Tests
        +1 mvninstall 13m 56s trunk passed
        +1 compile 0m 34s trunk passed
        +1 checkstyle 0m 19s trunk passed
        +1 mvnsite 0m 31s trunk passed
        -1 findbugs 0m 49s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager in trunk has 5 extant Findbugs warnings.
        +1 javadoc 0m 22s trunk passed
              Patch Compile Tests
        +1 mvninstall 0m 28s the patch passed
        +1 compile 0m 30s the patch passed
        +1 javac 0m 30s the patch passed
        -0 checkstyle 0m 18s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager: The patch generated 3 new + 35 unchanged - 0 fixed = 38 total (was 35)
        +1 mvnsite 0m 30s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 51s the patch passed
        +1 javadoc 0m 15s the patch passed
              Other Tests
        +1 unit 12m 53s hadoop-yarn-server-nodemanager in the patch passed.
        +1 asflicense 0m 19s The patch does not generate ASF License warnings.
        34m 10s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-3254
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12877669/YARN-3254-003.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux d361379b9de5 3.13.0-116-generic #163-Ubuntu SMP Fri Mar 31 14:13:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / b0e78ae
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        findbugs https://builds.apache.org/job/PreCommit-YARN-Build/16471/artifact/patchprocess/branch-findbugs-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-warnings.html
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/16471/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16471/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16471/console
        Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Sunil G Can you pls review the patch?

        sunilg Sunil G added a comment -

        Thanks Suma Shivaprasad
        Generally patch looks fine. Few minor comments.

        1. I think DirectoryCollection#getErroredDirs is a public api. Could u please mark as evolving and some more information in api. I think existing java doc is not that great there. However its better we do that.
        2. fullLocalDirsList could be renamed as diskFullLocalDirsList or some better name similar for logdirs as well.
        suma.shivaprasad Suma Shivaprasad added a comment -

        Thanks Sunil G Will update patch to address comments.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Attached patch with review comments addressed

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 13s Docker mode activated.
              Prechecks
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
              trunk Compile Tests
        +1 mvninstall 15m 37s trunk passed
        +1 compile 0m 34s trunk passed
        +1 checkstyle 0m 20s trunk passed
        +1 mvnsite 0m 31s trunk passed
        -1 findbugs 0m 43s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager in trunk has 5 extant Findbugs warnings.
        +1 javadoc 0m 17s trunk passed
              Patch Compile Tests
        +1 mvninstall 0m 25s the patch passed
        +1 compile 0m 26s the patch passed
        +1 javac 0m 26s the patch passed
        -0 checkstyle 0m 16s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager: The patch generated 6 new + 36 unchanged - 0 fixed = 42 total (was 36)
        +1 mvnsite 0m 26s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 48s the patch passed
        +1 javadoc 0m 14s the patch passed
              Other Tests
        +1 unit 13m 1s hadoop-yarn-server-nodemanager in the patch passed.
        +1 asflicense 0m 13s The patch does not generate ASF License warnings.
        35m 20s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-3254
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12879708/YARN-3254-004.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux dad58c08dfee 3.13.0-123-generic #172-Ubuntu SMP Mon Jun 26 18:04:35 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / fbb7d6b
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        findbugs https://builds.apache.org/job/PreCommit-YARN-Build/16629/artifact/patchprocess/branch-findbugs-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-warnings.html
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/16629/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16629/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16629/console
        Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        aw Allen Wittenauer added a comment -

        What does "full" mean?

        • out of inodes?
        • out of space?
        • out of writable space? (eg, root reserved space can't be written to)
        • out of quota? (eg, zfs set quota=foo)
          ....
        sunilg Sunil G added a comment -

        In DirectoryCollection.isDiskUsageOverPercentageLimit(), we use File#getUsableSpace and File#getTotalSpace to get a disk usage information and mark disks as FULL if used size is over a threshold. So its mostly about disk space related for now.

        In latest patch, new variables are renamed to diskFullLocalDirsList etc.

        leftnoteasy Wangda Tan added a comment -

        I think we need to clearly mention that in the jmx info: usable space is below some percentage or no more usable space.

        suma.shivaprasad Suma Shivaprasad added a comment - - edited

        Updated the patch to display the exact root cause for the disk error/capacity exceeded cases. These error diagnostics were already available in DirectoryCollection earlier but was ignored and not surfaced in the health report. Along with the ratio of disks marked as unhealthy for local/log dirs, the reason why each of them was marked unhealthy will be surfaced in health report. Sample errors below

        1/1 local-dirs have errors: [ /invalidDir1 : Cannot create directory: /invalidDir1 ] 1/1 log-dirs usable space is below configured utilization percentage/no more usable space [ /hadoop-3.0.0-beta1-SNAPSHOT/logs/userlogs : used space above threshold of 1.0% ]
        
        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 1m 52s Docker mode activated.
              Prechecks
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
              trunk Compile Tests
        +1 mvninstall 13m 32s trunk passed
        +1 compile 0m 27s trunk passed
        +1 checkstyle 0m 16s trunk passed
        +1 mvnsite 0m 26s trunk passed
        -1 findbugs 0m 42s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager in trunk has 5 extant Findbugs warnings.
        +1 javadoc 0m 17s trunk passed
              Patch Compile Tests
        +1 mvninstall 0m 23s the patch passed
        +1 compile 0m 23s the patch passed
        +1 javac 0m 23s the patch passed
        -0 checkstyle 0m 14s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager: The patch generated 14 new + 35 unchanged - 0 fixed = 49 total (was 35)
        +1 mvnsite 0m 23s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 48s the patch passed
        +1 javadoc 0m 13s the patch passed
              Other Tests
        +1 unit 13m 13s hadoop-yarn-server-nodemanager in the patch passed.
        +1 asflicense 0m 12s The patch does not generate ASF License warnings.
        34m 26s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-3254
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12880458/YARN-3254-005.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 6023976564c6 4.4.0-43-generic #63-Ubuntu SMP Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / f44b349
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        findbugs https://builds.apache.org/job/PreCommit-YARN-Build/16714/artifact/patchprocess/branch-findbugs-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-warnings.html
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/16714/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16714/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16714/console
        Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Sunil G Can you pls review the updated patch?

        sunilg Sunil G added a comment -

        Thanks Suma Shivaprasad

        Some more comments

        1. unused import java.util.NoSuchElementException
        2. Java doc could also add param info as we ill new apis such as DirectoryCollection#getDirectoryErrorInfo etc
        3. Its better to use errorInformation instead of getValue.
          directoryErrorInfo.put(entry.getKey(), entry.getValue());
          
        4. Could below message be kept at class level in LocalDirsHandlerService
          final String diskCapacityExceededErrorMsg
          
        5. One doubt in DirectoryCollection.checkDirs()
          As per latest patch, directoryErrorInfo is the super set which contains dirs from errorDirs, fullDirs and nothing more.
          Now while buildDiskErrorReport call, directoryCollection.isDiskUnHealthy is invoked for erroredLocal/LogDirsList and diskFullLocal/LogDirsList. I think this is not needed as contents from errorDirs and fillDirs are in that map for sure. In that case, could we skip this check and remove that api. Please correct me if I missed something here.
        ajisakaa Akira Ajisaka added a comment -

        Thanks Wangda Tan for the reply! I commented on HADOOP-13714 to loose the guideline.

        suma.shivaprasad Suma Shivaprasad added a comment -

        Thanks Sunil G. Attached patched with review comments addressed.

        unused import java.util.NoSuchElementException
        --> Removed
        Java doc could also add param info as we ill new apis such as DirectoryCollection#getDirectoryErrorInfo etc
        Its better to use errorInformation instead of getValue.
        directoryErrorInfo.put(entry.getKey(), entry.getValue());
        --> Fixed
        Could below message be kept at class level in LocalDirsHandlerService
        final String diskCapacityExceededErrorMsg
        --> Fixed
        One doubt in DirectoryCollection.checkDirs()
        As per latest patch, directoryErrorInfo is the super set which contains dirs from errorDirs, fullDirs and nothing more.
        Now while buildDiskErrorReport call, directoryCollection.isDiskUnHealthy is invoked for erroredLocal/LogDirsList and diskFullLocal/LogDirsList. I think this is not needed as contents from errorDirs and fillDirs are in that map for sure. In that case, could we skip this check and remove that api. Please correct me if I missed something here.
        -->Thanks for catching this. There was one case where the errorDirs was being updated but directoryErrorInfo was not being updated i.e in createNonExistentDirs which caused the lookup to return null. Have fixed that as part of the updated patch. Not sure if any other cases exist. Hence added a check to just be safe with the error information retrieval.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 15s Docker mode activated.
              Prechecks
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
              trunk Compile Tests
        +1 mvninstall 13m 17s trunk passed
        +1 compile 0m 27s trunk passed
        +1 checkstyle 0m 18s trunk passed
        +1 mvnsite 0m 26s trunk passed
        -1 findbugs 0m 43s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager in trunk has 5 extant Findbugs warnings.
        +1 javadoc 0m 14s trunk passed
              Patch Compile Tests
        +1 mvninstall 0m 24s the patch passed
        +1 compile 0m 25s the patch passed
        +1 javac 0m 25s the patch passed
        -0 checkstyle 0m 16s hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager: The patch generated 17 new + 35 unchanged - 0 fixed = 52 total (was 35)
        +1 mvnsite 0m 24s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 45s the patch passed
        +1 javadoc 0m 14s the patch passed
              Other Tests
        +1 unit 13m 25s hadoop-yarn-server-nodemanager in the patch passed.
        +1 asflicense 0m 15s The patch does not generate ASF License warnings.
        33m 2s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Issue YARN-3254
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12880716/YARN-3254-006.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e8e075be5529 4.4.0-43-generic #63-Ubuntu SMP Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / adb84f3
        Default Java 1.8.0_131
        findbugs v3.1.0-RC1
        findbugs https://builds.apache.org/job/PreCommit-YARN-Build/16754/artifact/patchprocess/branch-findbugs-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager-warnings.html
        checkstyle https://builds.apache.org/job/PreCommit-YARN-Build/16754/artifact/patchprocess/diff-checkstyle-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-server_hadoop-yarn-server-nodemanager.txt
        Test Results https://builds.apache.org/job/PreCommit-YARN-Build/16754/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/16754/console
        Powered by Apache Yetus 0.6.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        sunilg Sunil G added a comment -

        Thanks Suma Shivaprasad
        Latest patch seems fine to me. I will commit the patch later today if there are no objections.

        sunilg Sunil G added a comment -

        Committed to branch2/trunk. Thanks Suma Shivaprasad.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #12203 (See https://builds.apache.org/job/Hadoop-trunk-Commit/12203/)
        YARN-3254. HealthReport should include disk full information. (sunilg: rev f9a0e2338150f1bd3ba2c29f76979183fd3ed80c)

        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/TestDirectoryCollection.java
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/LocalDirsHandlerService.java
        • (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/DirectoryCollection.java

          People

          • Assignee:
            suma.shivaprasad Suma Shivaprasad
            Reporter:
            ajisakaa Akira Ajisaka
          • Votes:
            0 Vote for this issue
            Watchers:
            12 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development