Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-3143

RM Apps REST API can return NPE or entries missing id and other fields

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.2
    • Fix Version/s: 2.7.0
    • Component/s: webapp
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      I'm seeing intermittent null pointer exceptions being returned by
      the YARN Apps REST API.

      For example:

      http://{cluster}:{port}/ws/v1/cluster/apps?finalStatus=UNDEFINED
      

      JSON Response was:

      {"RemoteException":{"exception":"NullPointerException","javaClassName":"java.lang.NullPointerException"}}
      

      At a glance appears to be only when we query for unfinished apps (i.e. finalStatus=UNDEFINED).

      Possibly related, when I do get back a list of apps, sometimes one or more of the apps will be missing most of the fields, like id, name, user, etc., and the fields that are present all have zero for the value.

      For example:

      {"progress":0.0,"clusterId":0,"applicationTags":"","startedTime":0,"finishedTime":0,"elapsedTime":0,"allocatedMB":0,"allocatedVCores":0,"runningContainers":0,"preemptedResourceMB":0,"preemptedResourceVCores":0,"numNonAMContainerPreempted":0,"numAMContainerPreempted":0}
      

      Let me know if there's any other information I can provide to help debug.

        Attachments

        1. YARN-3143.001.patch
          7 kB
          Jason Darrell Lowe

          Activity

            People

            • Assignee:
              jlowe Jason Darrell Lowe
              Reporter:
              kthrapp Kendall Thrapp
            • Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: