Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-2597

MiniYARNCluster should propagate reason for AHS not starting

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None

      Description

      If the AHS doesn't come up, your test run gets an exception telling you this fact -but the underlying cause is not propagated.

      As YARN services do record their failure cause, extracting and propagating this is trivial.

        Issue Links

          Activity

          stevel@apache.org Steve Loughran added a comment -

          Without the patch

          testContainerLaunchFailureHandling(org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell)  Time elapsed: 4.209 sec  <<< ERROR!
          org.apache.hadoop.yarn.exceptions.YarnRuntimeException: java.io.IOException: ApplicationHistoryServer failed to start. Final state is STOPPED
          	at org.apache.hadoop.yarn.server.MiniYARNCluster$ApplicationHistoryServerWrapper.serviceStart(MiniYARNCluster.java:736)
          	at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          	at org.apache.hadoop.service.CompositeService.serviceStart(CompositeService.java:120)
          	at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          	at org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell.setup(TestDistributedShell.java:92)
          
          

          With the patch

          
          

          testDSShellWithMultipleArgs(org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell) Time elapsed: 4.323 sec <<< ERROR!
          org.apache.hadoop.service.ServiceStateException: java.io.IOException: ApplicationHistoryServer failed to start. Final state is STOPPED
          at org.apache.hadoop.yarn.server.MiniYARNCluster$ApplicationHistoryServerWrapper.serviceStart(MiniYARNCluster.java:737)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.service.CompositeService.serviceStart(CompositeService.java:120)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell.setup(TestDistributedShell.java:92)
          Caused by: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: java.net.BindException: Problem binding to [0.0.0.0:10200] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
          at org.apache.hadoop.yarn.factories.impl.pb.RpcServerFactoryPBImpl.getServer(RpcServerFactoryPBImpl.java:139)
          at org.apache.hadoop.yarn.ipc.HadoopYarnProtoRPC.getServer(HadoopYarnProtoRPC.java:65)
          at org.apache.hadoop.yarn.ipc.YarnRPC.getServer(YarnRPC.java:54)
          at org.apache.hadoop.yarn.server.applicationhistoryservice.ApplicationHistoryClientService.serviceStart(ApplicationHistoryClientService.java:87)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.service.CompositeService.serviceStart(CompositeService.java:120)
          at org.apache.hadoop.yarn.server.applicationhistoryservice.ApplicationHistoryServer.serviceStart(ApplicationHistoryServer.java:109)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.yarn.server.MiniYARNCluster$ApplicationHistoryServerWrapper$1.run(MiniYARNCluster.java:726)
          Caused by: java.net.BindException: Problem binding to [0.0.0.0:10200] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
          at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:719)
          at org.apache.hadoop.ipc.Server.bind(Server.java:427)
          at org.apache.hadoop.ipc.Server$Listener.<init>(Server.java:576)
          at org.apache.hadoop.ipc.Server.<init>(Server.java:2291)
          at org.apache.hadoop.ipc.RPC$Server.<init>(RPC.java:935)
          at org.apache.hadoop.ipc.ProtobufRpcEngine$Server.<init>(ProtobufRpcEngine.java:537)
          at org.apache.hadoop.ipc.ProtobufRpcEngine.getServer(ProtobufRpcEngine.java:512)
          at org.apache.hadoop.ipc.RPC$Builder.build(RPC.java:780)
          at org.apache.hadoop.yarn.factories.impl.pb.RpcServerFactoryPBImpl.createServer(RpcServerFactoryPBImpl.java:169)
          at org.apache.hadoop.yarn.factories.impl.pb.RpcServerFactoryPBImpl.getServer(RpcServerFactoryPBImpl.java:132)
          at org.apache.hadoop.yarn.ipc.HadoopYarnProtoRPC.getServer(HadoopYarnProtoRPC.java:65)
          at org.apache.hadoop.yarn.ipc.YarnRPC.getServer(YarnRPC.java:54)
          at org.apache.hadoop.yarn.server.applicationhistoryservice.ApplicationHistoryClientService.serviceStart(ApplicationHistoryClientService.java:87)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.service.CompositeService.serviceStart(CompositeService.java:120)
          at org.apache.hadoop.yarn.server.applicationhistoryservice.ApplicationHistoryServer.serviceStart(ApplicationHistoryServer.java:109)
          at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
          at org.apache.hadoop.yarn.server.MiniYARNCluster$ApplicationHistoryServerWrapper$1.run(MiniYARNCluster.java:726)

          
          
          stevel@apache.org Steve Loughran added a comment -

          propagates failure cause on AHS startup failure

          aw Allen Wittenauer added a comment -

          +1 lgtm

          hadoopqa Hadoop QA added a comment -



          +1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 6m 12s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 59s There were no new javac warning messages.
          +1 release audit 0m 19s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 24s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 30s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 0m 44s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 yarn tests 2m 20s Tests passed in hadoop-yarn-server-tests.
              20m 3s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12671016/YARN-2597-001.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / 3f82f58
          hadoop-yarn-server-tests test log https://builds.apache.org/job/PreCommit-YARN-Build/9195/artifact/patchprocess/testrun_hadoop-yarn-server-tests.txt
          Test Results https://builds.apache.org/job/PreCommit-YARN-Build/9195/testReport/
          Java 1.7.0_55
          uname Linux asf905.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-YARN-Build/9195/console

          This message was automatically generated.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #8476 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8476/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          • hadoop-yarn-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #406 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/406/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          • hadoop-yarn-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #413 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/413/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          • hadoop-yarn-project/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #1147 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1147/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2353 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2353/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          • hadoop-yarn-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #389 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/389/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2328 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2328/)
          YARN-2597 MiniYARNCluster should propagate reason for AHS not starting (stevel: rev a7201d635fc45b169ca3326bad48a3f781efe604)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/MiniYARNCluster.java
          • hadoop-yarn-project/CHANGES.txt

            People

            • Assignee:
              stevel@apache.org Steve Loughran
              Reporter:
              stevel@apache.org Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development