Hadoop YARN
  1. Hadoop YARN
  2. YARN-253

Container launch may fail if no files were localized

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.2-alpha
    • Fix Version/s: 2.0.3-alpha
    • Component/s: nodemanager
    • Labels:
      None

      Description

      This can be demonstrated with DistributedShell. The containers running the shell do not have any files to localize (if there is no shell script to copy) so if they run on a different NM to the AM (which does localize files), then they will fail since the appcache directory does not exist.

      1. YARN-253-test.patch
        1 kB
        Tom White
      2. YARN-253.patch
        2 kB
        Tom White
      3. YARN-253.patch
        4 kB
        Tom White
      4. YARN-253-20130108.txt
        3 kB
        Vinod Kumar Vavilapalli

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1308 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1308/)
          YARN-253. Fixed container-launch to not fail when there are no local resources to localize. Contributed by Tom White. (Revision 1430269)

          Result = FAILURE
          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1430269
          Files :

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/DefaultContainerExecutor.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/TestContainerManagerSecurity.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1280 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1280/)
          YARN-253. Fixed container-launch to not fail when there are no local resources to localize. Contributed by Tom White. (Revision 1430269)

          Result = FAILURE
          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1430269
          Files :

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/DefaultContainerExecutor.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/TestContainerManagerSecurity.java
          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #91 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/91/)
          YARN-253. Fixed container-launch to not fail when there are no local resources to localize. Contributed by Tom White. (Revision 1430269)

          Result = SUCCESS
          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1430269
          Files :

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/DefaultContainerExecutor.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/TestContainerManagerSecurity.java
          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3190 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3190/)
          YARN-253. Fixed container-launch to not fail when there are no local resources to localize. Contributed by Tom White. (Revision 1430269)

          Result = SUCCESS
          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1430269
          Files :

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/DefaultContainerExecutor.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests/src/test/java/org/apache/hadoop/yarn/server/TestContainerManagerSecurity.java
          Vinod Kumar Vavilapalli added a comment -

          I just committed this to trunk and branch-2. Thanks Tom!

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12563743/YARN-253-20130108.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/324//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/324//console

          This message is automatically generated.

          Vinod Kumar Vavilapalli added a comment -

          Same patch without TestDistributedShell changes.

          Vinod Kumar Vavilapalli added a comment -

          Looking at LCE, it seems to handle this case already since create_container_directories uses mkdirs which will create parent directories as needed.

          Yes, you are right, LCE already works with no resources. Just to be sure, I carefully looked through the code and confirmed the same.

          Cancelling the patch, to exclude the TestDistributedShell changes which are only increasing test time. The fixes that I suggested for TestContainerManagerSecurity already validate the patch by failing without the changes consistently and passing with.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12560577/YARN-253.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/218//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/218//console

          This message is automatically generated.

          Tom White added a comment -

          New patch which removes code from TestContainerManagerSecurity.

          Tom White added a comment -

          Thanks Vinod. Looking at LCE, it seems to handle this case already since create_container_directories uses mkdirs which will create parent directories as needed.

          I'll create another patch which removes the comment and temp files.

          Vinod Kumar Vavilapalli added a comment -

          it was a known bug and the fix might be more involved that this simple fix

          Thanks for bringing it up Bikas.

          Thanks Tom for filing this. I was looking for the ticket that I remember I opened for this, but given I cannot find it now, we can use this one.

          It is a slightly more involved change than the current fix mainly because it needs work with LinuxContainerExecutor also. We need to create the dirs even in LCE case, and earlier I was thinking that it may be more complex as I thought that we may need some-kind of initApp() API. Creating this on demand and in a reentrant manner also seems a viable idea now, so we can do the same with LCE.

          Please also remove my comment (search for "work around bugs.") and the temp files in TestContainerManagerSecurity.

          Tom White added a comment -

          I see that you removed the change in MAPREDUCE-4427 because it was an unrelated bug, which made sense in the context of that work. I'm curious to hear if there's a better fix than creating parent directories on demand.

          Bikas Saha added a comment -

          I had posted an identical solution (the code has been refactored since then) in the initial patch for MAPREDUCE-4427. Vinod Kumar Vavilapalli pointed out to me that it was a known bug and the fix might be more involved that this simple fix. So I removed that fix from the patch. Would be good to double check with him once. I forget the jira tracking the known issue.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12555565/YARN-253.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/202//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/202//console

          This message is automatically generated.

          Tom White added a comment -

          This fixes the problem by creating parent directories if they don't already exist. Without the fix the test would fail about 4 times in 10; with the fix I didn't see a failure.

          Tom White added a comment -

          This change to the DS unit test exposes the problem by changing the mini YARN cluster to have multiple NMs and multiple local directories so that the appcache created by the AM is not necessarily the same one used by the shell container.

          Here's the stacktrace showing the failure:

          2012-11-30 18:01:02,729 WARN  [ContainersLauncher #0] launcher.ContainerLaunch (ContainerLaunch.java:call(247)) - Failed to launch container.
          java.io.FileNotFoundException: File /Users/tom/workspace/hadoop-2/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/target/org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell/org.apache.hadoop.yarn.applications.distributedshell.TestDistributedShell-localDir-nm-2_0/usercache/tom/appcache/application_1354298449311_0001 does not exist
                  at org.apache.hadoop.fs.RawLocalFileSystem.getFileStatus(RawLocalFileSystem.java:485)
                  at org.apache.hadoop.fs.FileSystem.primitiveMkdir(FileSystem.java:996)
                  at org.apache.hadoop.fs.DelegateToFileSystem.mkdir(DelegateToFileSystem.java:150)
                  at org.apache.hadoop.fs.FilterFs.mkdir(FilterFs.java:187)
                  at org.apache.hadoop.fs.FileContext$4.next(FileContext.java:712)
                  at org.apache.hadoop.fs.FileContext$4.next(FileContext.java:708)
                  at org.apache.hadoop.fs.FileContext$FSLinkResolver.resolve(FileContext.java:2361)
                  at org.apache.hadoop.fs.FileContext.mkdir(FileContext.java:708)
                  at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.createDir(DefaultContainerExecutor.java:332)
                  at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.launchContainer(DefaultContainerExecutor.java:128)
                  at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:242)
                  at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:68)
                  at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
                  at java.util.concurrent.FutureTask.run(FutureTask.java:138)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
                  at java.lang.Thread.run(Thread.java:680)
          

            People

            • Assignee:
              Tom White
              Reporter:
              Tom White
            • Votes:
              0 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development