Hadoop YARN
  1. Hadoop YARN
  2. YARN-174

TestNodeStatusUpdater is failing in trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 2.0.2-alpha, 0.23.5
    • Component/s: nodemanager
    • Labels:
      None

      Description

      2012-10-19 12:18:23,941 FATAL [Node Status Updater] nodemanager.NodeManager (NodeManager.java:initAndStartNodeManager(277)) - Error starting NodeManager
      org.apache.hadoop.yarn.YarnException: ${yarn.log.dir}/userlogs is not a valid path. Path should be with file scheme or without scheme
              at org.apache.hadoop.yarn.server.nodemanager.LocalDirsHandlerService.validatePaths(LocalDirsHandlerService.java:321)
              at org.apache.hadoop.yarn.server.nodemanager.LocalDirsHandlerService$MonitoringTimerTask.<init>(LocalDirsHandlerService.java:95)
              at org.apache.hadoop.yarn.server.nodemanager.LocalDirsHandlerService.init(LocalDirsHandlerService.java:123)
              at org.apache.hadoop.yarn.service.CompositeService.init(CompositeService.java:58)
              at org.apache.hadoop.yarn.server.nodemanager.NodeHealthCheckerService.init(NodeHealthCheckerService.java:48)
              at org.apache.hadoop.yarn.service.CompositeService.init(CompositeService.java:58)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.init(NodeManager.java:165)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:274)
              at org.apache.hadoop.yarn.server.nodemanager.NodeManager.stateChanged(NodeManager.java:256)
              at org.apache.hadoop.yarn.service.AbstractService.changeState(AbstractService.java:163)
              at org.apache.hadoop.yarn.service.AbstractService.stop(AbstractService.java:112)
              at org.apache.hadoop.yarn.server.nodemanager.NodeStatusUpdaterImpl.stop(NodeStatusUpdaterImpl.java:149)
              at org.apache.hadoop.yarn.server.nodemanager.NodeStatusUpdaterImpl.reboot(NodeStatusUpdaterImpl.java:157)
              at org.apache.hadoop.yarn.server.nodemanager.NodeStatusUpdaterImpl.access$900(NodeStatusUpdaterImpl.java:63)
              at org.apache.hadoop.yarn.server.nodemanager.NodeStatusUpdaterImpl$1.run(NodeStatusUpdaterImpl.java:357)
      

      The NM then calls System.exit(-1), which makes the unit test exit and produces an error that is hard to track down.

      1. YARN-174.patch
        3 kB
        Sandy Ryza
      2. YARN-174-20121022.txt
        2 kB
        Vinod Kumar Vavilapalli

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1234 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1234/)
        YARN-174. Modify NodeManager to pass the user's configuration even when rebooting. Contributed by Vinod Kumar Vavilapalli. (Revision 1401086)

        Result = SUCCESS
        vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401086
        Files :

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1204 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1204/)
        YARN-174. Modify NodeManager to pass the user's configuration even when rebooting. Contributed by Vinod Kumar Vavilapalli. (Revision 1401086)

        Result = SUCCESS
        vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401086
        Files :

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #413 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/413/)
        YARN-174. Modify NodeManager to pass the user's configuration even when rebooting. Contributed by Vinod Kumar Vavilapalli.
        svn merge --ignore-ancestry -c 1401086 ../../trunk/ (Revision 1401089)

        Result = SUCCESS
        vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401089
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
        Hudson added a comment -

        Integrated in Hadoop-Yarn-trunk #12 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/12/)
        YARN-174. Modify NodeManager to pass the user's configuration even when rebooting. Contributed by Vinod Kumar Vavilapalli. (Revision 1401086)

        Result = FAILURE
        vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401086
        Files :

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
        Hudson added a comment -

        Integrated in Hadoop-trunk-Commit #2909 (See https://builds.apache.org/job/Hadoop-trunk-Commit/2909/)
        YARN-174. Modify NodeManager to pass the user's configuration even when rebooting. Contributed by Vinod Kumar Vavilapalli. (Revision 1401086)

        Result = SUCCESS
        vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1401086
        Files :

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
        Vinod Kumar Vavilapalli added a comment -

        Thanks for the review Bobby. I just committed this to trunk, branch-2 and branch-0.23.

        Robert Joseph Evans added a comment -

        The change is small and does fix the test so I am +1 on the change. Feel free to check it in Vinod. I would like to see the System.exit replaced by a ExitUtil.terminate, but that can wait for another JIRA.

        Sandy Ryza added a comment -

        Sorry, missed your comment on Friday. Thanks for taking it on!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12550324/YARN-174-20121022.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-YARN-Build/111//testReport/
        Console output: https://builds.apache.org/job/PreCommit-YARN-Build/111//console

        This message is automatically generated.

        Vinod Kumar Vavilapalli added a comment -

        This fixes the issue, the test passes after the patch.

        Vinod Kumar Vavilapalli added a comment -

        Sandy, trunk builds are all failing because of this. I am taking this over from you, hope you don't mind. Tx.

        Vinod Kumar Vavilapalli added a comment -

        Sandy, we shouldn't have any methods to override configuration, init() method exists solely for this reason. So createRebootConfiguration() isn't the correct way.

        The problem is that we are creating a new configuration on reboot, instead of using the configuration that user passed in during init. We should fix that.

        Sandy Ryza added a comment -

        Aaah, I was running into this when testing for YARN-170 and thought it was a problem with my code.


          People

          • Assignee:
            Vinod Kumar Vavilapalli
            Reporter:
            Robert Joseph Evans
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development