Hadoop YARN
  1. Hadoop YARN
  2. YARN-1117

Improve help message for $ yarn applications and $yarn node

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.1-beta
    • Component/s: client
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      There is standardization of help message in YARN-1080. It is nice to have similar changes for $ yarn appications and yarn node

      1. YARN-1117.1.patch
        13 kB
        Xuan Gong
      2. YARN-1117.2.patch
        15 kB
        Xuan Gong
      3. YARN-1117.3.patch
        13 kB
        Xuan Gong

        Issue Links

          Activity

          Tassapol Athiapinya created issue -
          Xuan Gong made changes -
          Field Original Value New Value
          Assignee Xuan Gong [ xgong ]
          Xuan Gong made changes -
          Link This issue duplicates YARN-1118 [ YARN-1118 ]
          Xuan Gong made changes -
          Description There is standardization of help message in YARN-1080. It is nice to have similar changes for $ yarn appications There is standardization of help message in YARN-1080. It is nice to have similar changes for $ yarn appications and yarn node
          Xuan Gong made changes -
          Summary Improve help message for $ yarn applications Improve help message for $ yarn applications and $yarn node
          Allen Wittenauer made changes -
          Link This issue is related to HADOOP-9902 [ HADOOP-9902 ]
          Xuan Gong made changes -
          Attachment YARN-1117.1.patch [ 12600652 ]
          Xuan Gong made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12600652/YARN-1117.1.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The following test timeouts occurred in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common:

          org.apache.hadoop.yarn.client.api.impl.TestYarnClient

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/1795//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/1795//console

          This message is automatically generated.

          Xuan Gong made changes -
          Attachment YARN-1117.2.patch [ 12600671 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12600671/YARN-1117.2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/1797//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/1797//console

          This message is automatically generated.

          Vinod Kumar Vavilapalli added a comment -

          ToolRunner should return a non-zero exit code instead of throwing exceptions.

          Also, not caused by your patch, but the help output is really badly formatted for both the commands. Can you try to fix it?

          Vinod Kumar Vavilapalli made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Xuan Gong made changes -
          Attachment YARN-1117.3.patch [ 12600689 ]
          Xuan Gong added a comment -

          Return non-zero exit code instead of throwing exceptions. Fix help messages.

          Xuan Gong made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12600689/YARN-1117.3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-YARN-Build/1800//testReport/
          Console output: https://builds.apache.org/job/PreCommit-YARN-Build/1800//console

          This message is automatically generated.

          Vinod Kumar Vavilapalli added a comment -

          Looks good, +1. Checking this in.

          Vinod Kumar Vavilapalli added a comment -

          Committed this to trunk, branch-2 and branch-2.1-beta. Thanks Xuan!

          Vinod Kumar Vavilapalli made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Fix Version/s 2.1.1-beta [ 12324806 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #4355 (See https://builds.apache.org/job/Hadoop-trunk-Commit/4355/)
          YARN-1117. Improved help messages for "yarn application" and "yarn node" commands. Contributed by Xuan Gong. (vinodkv: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1519117)

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/ApplicationCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/NodeCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/api/impl/TestYarnClient.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestYarnCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/java/org/apache/hadoop/yarn/util/ConverterUtils.java
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #318 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/318/)
          YARN-1117. Improved help messages for "yarn application" and "yarn node" commands. Contributed by Xuan Gong. (vinodkv: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1519117)

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/ApplicationCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/NodeCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/api/impl/TestYarnClient.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestYarnCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/java/org/apache/hadoop/yarn/util/ConverterUtils.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1508 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1508/)
          YARN-1117. Improved help messages for "yarn application" and "yarn node" commands. Contributed by Xuan Gong. (vinodkv: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1519117)

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/ApplicationCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/NodeCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/api/impl/TestYarnClient.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestYarnCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/java/org/apache/hadoop/yarn/util/ConverterUtils.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1535 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1535/)
          YARN-1117. Improved help messages for "yarn application" and "yarn node" commands. Contributed by Xuan Gong. (vinodkv: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1519117)

          • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/ApplicationCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/NodeCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/api/impl/TestYarnClient.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestYarnCLI.java
          • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/java/org/apache/hadoop/yarn/util/ConverterUtils.java
          Arun C Murthy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Patch Available Patch Available Open Open
          1h 42m 1 Vinod Kumar Vavilapalli 30/Aug/13 00:07
          Open Open Patch Available Patch Available
          1d 1h 41m 2 Xuan Gong 30/Aug/13 00:44
          Patch Available Patch Available Resolved Resolved
          23h 43m 1 Vinod Kumar Vavilapalli 31/Aug/13 00:27
          Resolved Resolved Closed Closed
          25d 6m 1 Arun C Murthy 25/Sep/13 00:33

            People

            • Assignee:
              Xuan Gong
              Reporter:
              Tassapol Athiapinya
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development