Hadoop YARN
  1. Hadoop YARN
  2. YARN-1022

Unnecessary INFO logs in AMRMClientAsync

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.2.0, 2.3.0
    • Fix Version/s: 2.3.0
    • Component/s: None
    • Labels:
    • Hadoop Flags:
      Reviewed
    • Target Version/s:

      Description

      Logs like the following should be debug or else every legitimate stop causes unnecessary exception traces in the logs.

      464 2013-08-03 20:01:34,459 INFO [AMRM Heartbeater thread] org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl: Heartbeater interrupted
      465 java.lang.InterruptedException: sleep interrupted
      466 at java.lang.Thread.sleep(Native Method)
      467 at org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl$HeartbeatThread.run(AMRMClientAsyncImpl.java:249)
      468 2013-08-03 20:01:34,460 INFO [AMRM Callback Handler Thread] org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl: Interrupted while waiting for queue
      469 java.lang.InterruptedException
      470 at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.reportInterruptAfterWait(AbstractQueuedSynchronizer. java:1961)
      471 at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:1996)
      472 at java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:399)
      473 at org.apache.hadoop.yarn.client.api.async.impl.AMRMClientAsyncImpl$CallbackHandlerThread.run(AMRMClientAsyncImpl.java:275)

        Activity

        Bikas Saha created issue -
        Omkar Vinit Joshi made changes -
        Field Original Value New Value
        Labels newbie
        Arun C Murthy made changes -
        Fix Version/s 2.1.2-beta [ 12325051 ]
        Fix Version/s 2.1.1-beta [ 12324806 ]
        Sandy Ryza made changes -
        Fix Version/s 2.2.1 [ 12325256 ]
        Fix Version/s 2.2.0 [ 12325051 ]
        Sandy Ryza made changes -
        Fix Version/s 2.2.1 [ 12325256 ]
        Target Version/s 2.2.1 [ 12325256 ]
        haosdent made changes -
        Attachment YARN-1022.patch [ 12610498 ]
        haosdent added a comment -

        Change the log level form info to debug.

        Bikas Saha made changes -
        Assignee haosdent [ haosdent@gmail.com ]
        Bikas Saha added a comment -

        Thanks! +1. Committed.

        Bikas Saha made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Fix Version/s 2.2.1 [ 12325256 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #4660 (See https://builds.apache.org/job/Hadoop-trunk-Commit/4660/)
        YARN-1022. Unnecessary INFO logs in AMRMClientAsync (haosdent via bikas) (bikas: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1536248)

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/api/async/impl/AMRMClientAsyncImpl.java
        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #376 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/376/)
        YARN-1022. Unnecessary INFO logs in AMRMClientAsync (haosdent via bikas) (bikas: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1536248)

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/api/async/impl/AMRMClientAsyncImpl.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1592 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1592/)
        YARN-1022. Unnecessary INFO logs in AMRMClientAsync (haosdent via bikas) (bikas: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1536248)

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/api/async/impl/AMRMClientAsyncImpl.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1566 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1566/)
        YARN-1022. Unnecessary INFO logs in AMRMClientAsync (haosdent via bikas) (bikas: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1536248)

        • /hadoop/common/trunk/hadoop-yarn-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/api/async/impl/AMRMClientAsyncImpl.java
        Vinod Kumar Vavilapalli made changes -
        Priority Minor [ 4 ] Trivial [ 5 ]
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Sietse T. Au added a comment -

        The patch is targeting the wrong LOG.info, it should be the LOG.info caused by "AMRMClientAsyncImpl.java:275", as we see in the logs in the description.
        LOG.info("Interrupted while waiting for queue", ex); -> LOG.debug("Interrupted while waiting for queue", ex); on line 277.

        Sietse T. Au made changes -
        Affects Version/s 2.3.0 [ 12325256 ]
        Sietse T. Au made changes -
        Affects Version/s 2.2.0 [ 12325051 ]

          People

          • Assignee:
            haosdent
            Reporter:
            Bikas Saha
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development