Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-4570

Conflicting dependencies in full lib distribution

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.24
    • Fix Version/s: 2.3.28, 2.5
    • Component/s: Other
    • Labels:
      None
    • Environment:

      Tested both with Java 8 on Ubuntu 14 & Windows 7.

      Description

      Error when launching simple struts 2 application when all dependencies are added to WEB-INF/lib.

      It appears that some struts-plugin.xml are conflicting :

      • struts2-gxp-plugin
      • struts2-portlet-plugin

      If those dependencies are removed, then the Spring struts integration plugin complains because it is not properly initialized.
      It would be nice to be able to download a simple set of plugins with can be integrated to a webapp without worring about those dependencies.

      Full stack traces :

      Console
      nov. 20, 2015 8:46:45 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
      AVERTISSEMENT: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:DemoStruts' did not find a matching property.
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Server version:        Apache Tomcat/8.0.28
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Server built:          Oct 7 2015 18:25:21 UTC
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Server number:         8.0.28.0
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: OS Name:               Windows 7
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: OS Version:            6.1
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Architecture:          amd64
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Java Home:             C:\Program Files\Java\jre1.8.0_65
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: JVM Version:           1.8.0_65-b17
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: JVM Vendor:            Oracle Corporation
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: CATALINA_BASE:         C:\Users\ILI16\Documents\PERL\workspaceEclipse\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: CATALINA_HOME:         C:\Program Files\apache-tomcat-8.0.28
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Command line argument: -Dcatalina.base=C:\Users\ILI16\Documents\PERL\workspaceEclipse\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Command line argument: -Dcatalina.home=C:\Program Files\apache-tomcat-8.0.28
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Command line argument: -Dwtp.deploy=C:\Users\ILI16\Documents\PERL\workspaceEclipse\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Command line argument: -Djava.endorsed.dirs=C:\Program Files\apache-tomcat-8.0.28\endorsed
      nov. 20, 2015 8:46:45 AM org.apache.catalina.startup.VersionLoggerListener log
      INFOS: Command line argument: -Dfile.encoding=Cp1252
      nov. 20, 2015 8:46:45 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
      INFOS: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre1.8.0_65\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\ProgramData\Oracle\Java\javapath;C:\wamp\bin\perl\site\bin;C:\wamp\bin\perl\bin;C:\Perl\site\bin;C:\Perl\bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Strawberry\c\bin;C:\Strawberry\perl\site\bin;C:\Strawberry\perl\bin;C:\Windows\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;.
      nov. 20, 2015 8:46:46 AM org.apache.coyote.AbstractProtocol init
      INFOS: Initializing ProtocolHandler ["http-nio-8080"]
      nov. 20, 2015 8:46:46 AM org.apache.tomcat.util.net.NioSelectorPool getSharedSelector
      INFOS: Using a shared selector for servlet write/read
      nov. 20, 2015 8:46:46 AM org.apache.coyote.AbstractProtocol init
      INFOS: Initializing ProtocolHandler ["ajp-nio-8009"]
      nov. 20, 2015 8:46:46 AM org.apache.tomcat.util.net.NioSelectorPool getSharedSelector
      INFOS: Using a shared selector for servlet write/read
      nov. 20, 2015 8:46:46 AM org.apache.catalina.startup.Catalina load
      INFOS: Initialization processed in 390 ms
      nov. 20, 2015 8:46:46 AM org.apache.catalina.core.StandardService startInternal
      INFOS: Démarrage du service Catalina
      nov. 20, 2015 8:46:46 AM org.apache.catalina.core.StandardEngine startInternal
      INFOS: Starting Servlet Engine: Apache Tomcat/8.0.28
      nov. 20, 2015 8:46:47 AM org.apache.jasper.servlet.TldScanner scanJars
      INFOS: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
      nov. 20, 2015 8:46:47 AM com.opensymphony.xwork2.config.providers.XmlConfigurationProvider info
      INFOS: Parsing configuration file [struts-default.xml]
      nov. 20, 2015 8:46:48 AM com.opensymphony.xwork2.config.providers.XmlConfigurationProvider info
      INFOS: Parsing configuration file [struts-plugin.xml]
      nov. 20, 2015 8:46:48 AM org.apache.struts2.dispatcher.Dispatcher error
      GRAVE: Dispatcher initialization failed
      Unable to load configuration. - bean - jar:file:/C:/Users/ILI16/Documents/PERL/workspaceEclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/DemoStruts/WEB-INF/lib/struts2-gxp-plugin-2.3.24.1.jar!/struts-plugin.xml:8:162
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:70)
      	at org.apache.struts2.dispatcher.Dispatcher.getContainer(Dispatcher.java:967)
      	at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:435)
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:479)
      	at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
      	at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
      	at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)
      	at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)
      	at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4583)
      	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5207)
      	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: Unable to load bean: type:org.apache.struts2.views.gxp.inject.InjectedObjectContainer class:org.apache.struts2.views.gxp.inject.InjectedObjectContainer - bean - jar:file:/C:/Users/ILI16/Documents/PERL/workspaceEclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/DemoStruts/WEB-INF/lib/struts2-gxp-plugin-2.3.24.1.jar!/struts-plugin.xml:8:162
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:247)
      	at org.apache.struts2.config.StrutsXmlConfigurationProvider.register(StrutsXmlConfigurationProvider.java:102)
      	at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:240)
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
      	... 17 more
      Caused by: java.lang.ClassNotFoundException: org.apache.struts2.views.gxp.inject.InjectedObjectContainer
      	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1333)
      	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1167)
      	at com.opensymphony.xwork2.util.ClassLoaderUtil.loadClass(ClassLoaderUtil.java:152)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:218)
      	... 20 more
      
      nov. 20, 2015 8:46:48 AM org.apache.catalina.core.StandardContext filterStart
      GRAVE: Exception au démarrage du filtre struts2
      Unable to load configuration. - bean - jar:file:/C:/Users/ILI16/Documents/PERL/workspaceEclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/DemoStruts/WEB-INF/lib/struts2-gxp-plugin-2.3.24.1.jar!/struts-plugin.xml:8:162
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:493)
      	at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
      	at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
      	at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)
      	at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)
      	at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4583)
      	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5207)
      	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: Unable to load configuration. - bean - jar:file:/C:/Users/ILI16/Documents/PERL/workspaceEclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/DemoStruts/WEB-INF/lib/struts2-gxp-plugin-2.3.24.1.jar!/struts-plugin.xml:8:162
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:70)
      	at org.apache.struts2.dispatcher.Dispatcher.getContainer(Dispatcher.java:967)
      	at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:435)
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:479)
      	... 14 more
      Caused by: Unable to load bean: type:org.apache.struts2.views.gxp.inject.InjectedObjectContainer class:org.apache.struts2.views.gxp.inject.InjectedObjectContainer - bean - jar:file:/C:/Users/ILI16/Documents/PERL/workspaceEclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/DemoStruts/WEB-INF/lib/struts2-gxp-plugin-2.3.24.1.jar!/struts-plugin.xml:8:162
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:247)
      	at org.apache.struts2.config.StrutsXmlConfigurationProvider.register(StrutsXmlConfigurationProvider.java:102)
      	at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:240)
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
      	... 17 more
      Caused by: java.lang.ClassNotFoundException: org.apache.struts2.views.gxp.inject.InjectedObjectContainer
      	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1333)
      	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1167)
      	at com.opensymphony.xwork2.util.ClassLoaderUtil.loadClass(ClassLoaderUtil.java:152)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:218)
      	... 20 more
      
      nov. 20, 2015 8:46:48 AM org.apache.catalina.core.StandardContext startInternal
      GRAVE: One or more Filters failed to start. Full details will be found in the appropriate container log file
      nov. 20, 2015 8:46:48 AM org.apache.catalina.core.StandardContext startInternal
      GRAVE: Erreur de démarrage du contexte [/DemoStruts] suite aux erreurs précédentes
      nov. 20, 2015 8:46:48 AM org.apache.coyote.AbstractProtocol start
      INFOS: Starting ProtocolHandler ["http-nio-8080"]
      nov. 20, 2015 8:46:48 AM org.apache.coyote.AbstractProtocol start
      INFOS: Starting ProtocolHandler ["ajp-nio-8009"]
      nov. 20, 2015 8:46:48 AM org.apache.catalina.startup.Catalina start
      INFOS: Server startup in 2028 ms
      
      Console
      INFOS: Initializing Struts-Spring integration...
      nov. 20, 2015 9:05:37 AM org.apache.struts2.spring.StrutsSpringObjectFactory fatal
      GRAVE: ********** FATAL ERROR STARTING UP STRUTS-SPRING INTEGRATION **********
      Looks like the Spring listener was not configured for your web app! 
      Nothing will work until WebApplicationContextUtils returns a valid ApplicationContext.
      You might need to add the following to web.xml: 
          <listener>
              <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
          </listener>
      nov. 20, 2015 9:05:37 AM org.apache.struts2.dispatcher.Dispatcher error
      GRAVE: Dispatcher initialization failed
      java.lang.NullPointerException
      	at com.opensymphony.xwork2.spring.SpringObjectFactory.getClassInstance(SpringObjectFactory.java:245)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.verifyResultType(XmlConfigurationProvider.java:608)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addResultTypes(XmlConfigurationProvider.java:578)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addPackage(XmlConfigurationProvider.java:534)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadPackages(XmlConfigurationProvider.java:295)
      	at org.apache.struts2.config.StrutsXmlConfigurationProvider.loadPackages(StrutsXmlConfigurationProvider.java:112)
      	at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:264)
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
      	at org.apache.struts2.dispatcher.Dispatcher.getContainer(Dispatcher.java:967)
      	at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:435)
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:479)
      	at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
      	at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
      	at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)
      	at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)
      	at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4583)
      	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5207)
      	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      
      nov. 20, 2015 9:05:37 AM org.apache.catalina.core.StandardContext filterStart
      GRAVE: Exception au démarrage du filtre struts2
      Class: com.opensymphony.xwork2.spring.SpringObjectFactory
      File: SpringObjectFactory.java
      Method: getClassInstance
      Line: 245 - com/opensymphony/xwork2/spring/SpringObjectFactory.java:245:-1
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:493)
      	at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
      	at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
      	at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)
      	at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)
      	at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4583)
      	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5207)
      	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
      	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NullPointerException
      	at com.opensymphony.xwork2.spring.SpringObjectFactory.getClassInstance(SpringObjectFactory.java:245)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.verifyResultType(XmlConfigurationProvider.java:608)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addResultTypes(XmlConfigurationProvider.java:578)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addPackage(XmlConfigurationProvider.java:534)
      	at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadPackages(XmlConfigurationProvider.java:295)
      	at org.apache.struts2.config.StrutsXmlConfigurationProvider.loadPackages(StrutsXmlConfigurationProvider.java:112)
      	at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:264)
      	at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
      	at org.apache.struts2.dispatcher.Dispatcher.getContainer(Dispatcher.java:967)
      	at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:435)
      	at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:479)
      	... 14 more
      
      nov. 20, 2015 9:05:37 AM org.apache.catalina.core.StandardContext startInternal
      GRAVE: One or more Filters failed to start. Full details will be found in the appropriate container log file
      nov. 20, 2015 9:05:37 AM org.apache.catalina.core.StandardContext startInternal
      GRAVE: Erreur de démarrage du contexte [/DemoStruts] suite aux erreurs précédentes
      nov. 20, 2015 9:05:37 AM org.apache.coyote.AbstractProtocol start
      INFOS: Starting ProtocolHandler ["http-nio-8080"]
      nov. 20, 2015 9:05:37 AM org.apache.coyote.AbstractProtocol start
      INFOS: Starting ProtocolHandler ["ajp-nio-8009"]
      nov. 20, 2015 9:05:37 AM org.apache.catalina.startup.Catalina start
      INFOS: Server startup in 2359 ms
      

        Issue Links

          Activity

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Struts-JDK7-master #558 (See https://builds.apache.org/job/Struts-JDK7-master/558/)
          WW-4570 Cleans up ASM and assemblies (lukaszlenart: rev f03279fc1ae1524272b08a4d5e031f7304ea05c5)

          • (edit) assembly/src/main/assembly/min-lib.xml
          • (edit) assembly/src/main/assembly/lib.xml
          • (edit) assembly/src/main/assembly/all.xml
          • (edit) pom.xml
          jira-bot ASF subversion and git services added a comment -

          Commit f03279fc1ae1524272b08a4d5e031f7304ea05c5 in struts's branch refs/heads/master from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=f03279f ]

          WW-4570 Cleans up ASM and assemblies

          lukaszlenart Lukasz Lenart added a comment -

          hmmm... right, if you don't use the Convention plugin it doesn't make sense to put them there - I will drop those libs and will move the dependent class into the Convention plugin.

          dleberre Daniel Le Berre added a comment -

          I just downloaded the minimal set of libs for 2.5.5: the three asm jar do appear in the archive.

          I removed them and a basic struts app still works. I guess those libs have been added back inadvertently?

          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK7-master #495 (See https://builds.apache.org/job/Struts-JDK7-master/495/)
          WW-4570 Defines a minimal jar set to be used by users (cherry picked (lukaszlenart: rev da55360868adb1bf91b82df36b8ae603db7fac39)

          • assembly/pom.xml
          • assembly/src/main/assembly/min-lib.xml
            WW-4570 Uses proper schema for assembly descriptor (cherry picked from (lukaszlenart: rev 3573c1be5bfa4914adb8ed650c62f419bbf9475c)
          • assembly/src/main/assembly/lib.xml
          • assembly/src/main/assembly/src.xml
          • assembly/src/main/assembly/all.xml
          • assembly/src/main/assembly/docs.xml
          • assembly/src/main/assembly/apps.xml
            WW-4570 Drops ASM from minimal set of Jars (cherry picked from commit (lukaszlenart: rev e901ff68c9eae9afdf688aacbc54ad5fc0c13af2)
          • assembly/src/main/assembly/min-lib.xml
            WW-4570 Drops XWork core from min-lib (lukaszlenart: rev 37445b0ef46a0396d46f8d40dc0d63f763697f30)
          • assembly/src/main/assembly/min-lib.xml
          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK7-master #389 (See https://builds.apache.org/job/Struts-JDK7-master/389/)
          WW-4570 Defines a minimal jar set to be used by users (cherry picked (lukaszlenart: rev 103a655f4aa02453704e7ba84ea598eba1dc59a1)

          • assembly/src/main/assembly/min-lib.xml
          • assembly/pom.xml
            WW-4570 Uses proper schema for assembly descriptor (cherry picked from (lukaszlenart: rev a20aed381a8443f731deaf44d5855963a615e3a6)
          • assembly/src/main/assembly/all.xml
          • assembly/src/main/assembly/apps.xml
          • assembly/src/main/assembly/lib.xml
          • assembly/src/main/assembly/src.xml
          • assembly/src/main/assembly/docs.xml
            WW-4570 Drops ASM from minimal set of Jars (cherry picked from commit (lukaszlenart: rev fa41222859a73a47df5ddccf44f3db31e1726925)
          • assembly/src/main/assembly/min-lib.xml
            WW-4570 Drops XWork core from min-lib (lukaszlenart: rev e488353a05a56868a4744541aeb411869af2fb53)
          • assembly/src/main/assembly/min-lib.xml
          jira-bot ASF subversion and git services added a comment -

          Commit e488353a05a56868a4744541aeb411869af2fb53 in struts's branch refs/heads/master from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=e488353 ]

          WW-4570 Drops XWork core from min-lib

          jira-bot ASF subversion and git services added a comment -

          Commit fa41222859a73a47df5ddccf44f3db31e1726925 in struts's branch refs/heads/master from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=fa41222 ]

          WW-4570 Drops ASM from minimal set of Jars
          (cherry picked from commit 90dbf54)

          jira-bot ASF subversion and git services added a comment -

          Commit a20aed381a8443f731deaf44d5855963a615e3a6 in struts's branch refs/heads/master from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=a20aed3 ]

          WW-4570 Uses proper schema for assembly descriptor
          (cherry picked from commit b4a18d0)

          jira-bot ASF subversion and git services added a comment -

          Commit 103a655f4aa02453704e7ba84ea598eba1dc59a1 in struts's branch refs/heads/master from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=103a655 ]

          WW-4570 Defines a minimal jar set to be used by users
          (cherry picked from commit 5d26c6c)

          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK6-support-2.3 #934 (See https://builds.apache.org/job/Struts-JDK6-support-2.3/934/)
          WW-4570 Drops ASM from minimal set of Jars (lukaszlenart: rev 90dbf54bf49df2701d106d5f4813e0914ec13283)

          • assembly/src/main/assembly/min-lib.xml
          • assembly/pom.xml
          jira-bot ASF subversion and git services added a comment -

          Commit 90dbf54bf49df2701d106d5f4813e0914ec13283 in struts's branch refs/heads/support-2-3 from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=90dbf54 ]

          WW-4570 Drops ASM from minimal set of Jars

          dleberre Daniel Le Berre added a comment -

          Ok, thanks for the explanation. I will check how to use client side validation without the dojo plugin, since it is deprecated in 2.5.

          Thanks again for your prompt feedback.

          Have a nice WE,

          Daniel

          lukaszlenart Lukasz Lenart added a comment - - edited

          Right, asm is used by DefaultClassFinder but this class is used by the Convention Plugin for now - so it isn't a direct dependency and could be omitted Regarding the DOJO plugin I can add it but this plugin is marked as deprecated and was dropped in Struts 2.5 version. And as far I understand you don't it to enable client side validations.

          dleberre Daniel Le Berre added a comment -

          That's great!

          I noticed that you added the asm jar files to the minimal libs. Is there a specific reason for that? I did not noticed yet the need for those libs.

          When explaining the struts validation framework, it is nice to use the client side validation using javascript. Any chance to argue that the dojo plugin should be part of that minimal lib distribution

          Many thanks for the very prompt action.

          Regards,

          Daniel

          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK6-support-2.3 #933 (See https://builds.apache.org/job/Struts-JDK6-support-2.3/933/)
          WW-4570 Uses proper schema for assembly descriptor (lukaszlenart: rev b4a18d07e4f935a0a2a82c0fb7e3d179c075a776)

          • assembly/src/main/assembly/docs.xml
          • assembly/src/main/assembly/src.xml
          • assembly/src/main/assembly/lib.xml
          • assembly/src/main/assembly/all.xml
          • assembly/src/main/assembly/apps.xml
          hudson Hudson added a comment -

          SUCCESS: Integrated in Struts-JDK6-support-2.3 #932 (See https://builds.apache.org/job/Struts-JDK6-support-2.3/932/)
          WW-4570 Defines a minimal jar set to be used by users (lukaszlenart: rev 5d26c6c1e5ec466d231dcad4d70b670609b85248)

          • assembly/pom.xml
          • assembly/src/main/assembly/min-lib.xml
          jira-bot ASF subversion and git services added a comment -

          Commit b4a18d07e4f935a0a2a82c0fb7e3d179c075a776 in struts's branch refs/heads/support-2-3 from Lukasz Lenart
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=b4a18d0 ]

          WW-4570 Uses proper schema for assembly descriptor

          lukaszlenart Lukasz Lenart added a comment -

          I have created a dedicated assembly with minimal set of jars

          jira-bot ASF subversion and git services added a comment -

          Commit 5d26c6c1e5ec466d231dcad4d70b670609b85248 in struts's branch refs/heads/support-2-3 from Disabled - L-u-k-a-s-z Lenart - OpenSymphony
          [ https://git-wip-us.apache.org/repos/asf?p=struts.git;h=5d26c6c ]

          WW-4570 Defines a minimal jar set to be used by users

          dleberre Daniel Le Berre added a comment -

          Yep, this is what I used to build my minimal requirements. I just added the dojo plugin to have client side validation in javascript.

          It would be nice to have that minimal requirement libs downloadable as part of the distro, for newcomers.

          lukaszlenart Lukasz Lenart added a comment - - edited

          What about this page https://struts.apache.org/docs/simple-setup.html ? Looks a bit outdated but similar to what you want.

          dleberre Daniel Le Berre added a comment -

          Well, this is something close to what we are looking for
          The students do not use maven yet (they will use it next term). We build everything "by hand" right now. I selected a set of 10 jars to make a minimal struts 2 web app (do not pay attention to the versions, it was in 2013):

          commons-fileupload-1.3.1.jar  javassist-3.11.0.GA.jar
          commons-io-2.2.jar
          commons-lang3-3.1.jar
          commons-logging-1.1.3.jar
          freemarker-2.3.19.jar
          ognl-3.0.6.jar
          struts2-core-2.3.16.3.jar
          struts2-dojo-plugin-2.3.16.3.jar
          xwork-core-2.3.16.3.jar
          

          This is AFAIK the minimal requirements needed to play with Struts2.

          lukaszlenart Lukasz Lenart added a comment -

          Also there is a dedicated set of many different webapps here https://github.com/apache/struts-examples - we didn't release them but it can be easily fixed

          lukaszlenart Lukasz Lenart added a comment -

          Daniel Le Berre why don't you use the Example Applications package? http://struts.apache.org/download.cgi#struts23241

          dleberre Daniel Le Berre added a comment -

          Hi Lukas,

          We use Struts2 in the classroom. I ask the students to download Struts2 and to run an "Hello World" app. It used to work fine even if all libs where added in the lib directory in the past. It is no longer the case, thus one need to carefully check which jar to pick to run its first Struts2 app.

          It might be a good idea to have an archive with a small set of dependencies, which could be used to learn Struts2.

          lukaszlenart Lukasz Lenart added a comment -

          To use integration with Spring you must properly configure it as it was showed in the error message and in the docs http://struts.apache.org/docs/spring-plugin.html

          lukaszlenart Lukasz Lenart added a comment -

          Why you want to use all the plugins? The struts2-portlet-plugin can be used only in portlet environment as it requires dedicated PortalContext, it won't work in an ordinary servlet container.


            People

            • Assignee:
              lukaszlenart Lukasz Lenart
              Reporter:
              SirBigoo Soann Dewasme
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development