Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-4541

xwork-core (> 2.3.20) has a dependency to commons-lang3 (3.2) which is problematic with Java 5

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.3.20
    • Fix Version/s: 2.3.28
    • Component/s: None
    • Labels:
      None
    • Environment:

      JAVA 5

      Description

      Since the xwork-core version 2.3.20 there is a dependency to commons-lang3 version 3.2 which is defined in the struts2-parent POM file.
      But according to [1] commons-lang3 3.2 requires at least Java 6. Strictly speaking, Struts 2 versions higher than 2.3.20 needs Java 6.
      If you have a web project based on Java 5 and the commons-lang3 library is used, you will get a compile error.
      "class file has wrong version 50.0, should be 49.0"

      [1] https://commons.apache.org/proper/commons-lang/release-history.html

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pepsifan Jon Y.
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: