Uploaded image for project: 'WSS4J'
  1. WSS4J
  2. WSS-146

Upgrade opensaml dependency to 2.x line

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6
    • Component/s: None
    • Labels:
      None

      Description

      WSS4J has a dependency on opensaml 1.1. OpenSAML 1.1 is, for the most part, no longer supported (https://spaces.internet2.edu/display/OpenSAML/OS1Status).

      2.1 has been out for a while, and 2.2 was released in Oct. '08. The 2.x line is not backwards compatible with 1.1 so unfortunately it's not as simple as dropping in the newer jar.

        Attachments

        1. wss4j_opensaml2.1.0.patch
          542 kB
          Wim Vandenhaute
        2. wss4j_opensaml2.1.0_correct.patch
          575 kB
          Wim Vandenhaute
        3. wss4j_opensaml2.2.3.patch
          106 kB
          Brian McDonald
        4. wss4j-1.5.8-saml.patch
          378 kB
          Todd Dunst
        5. saml_port.patch.2
          139 kB
          Colm O hEigeartaigh

          Issue Links

            Activity

              People

              • Assignee:
                coheigea Colm O hEigeartaigh
                Reporter:
                jacorob Bob Jacoby
              • Votes:
                8 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: