Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-6595

Upgrade JUnit to v5.x

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 9.0.0-M1
    • Fix Version/s: 9.0.0-M1
    • Component/s: wicket
    • Labels:
      None

      Description

      Upgrade JUnit dependency from 4.12 to latest 5.x.

      This applies both on Wicket's unit tests themselves and also on the APIs exposed via ***Tester classes (like WicketTester, FormTester, TagTester, etc.)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mgrigorov Martin Tzvetanov Grigorov
                Reporter:
                mgrigorov Martin Tzvetanov Grigorov
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: