Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-6583

Upgrade Tests to Junit5

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9.0.0-M1
    • Component/s: wicket
    • Labels:
      None

      Description

      Since Junit 4 is no longer actively developed Wicket should upgrade to Junit 5 in a future release.

      To be able to use the new Junit 5 there should be an upgrade from Junit 4 to 5. Also the hard dependencies of WicketTester and other test classes to Junit 4 should be refactored out.

       

      Quick overview of migration from 4 to 5: 

      https://www.baeldung.com/junit-5-migration

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                renoth Johannes Renoth
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: