Wicket
  1. Wicket
  2. WICKET-5397

target.prependJavaScript and JQuery-Animation in IE8

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.11.0
    • Fix Version/s: 6.12.0, 7.0.0
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      IE8 on Windows 7, IE8 on Parallels on a MAC

      Description

      Copied from http://apache-wicket.1842946.n4.nabble.com/target-prependJavaScript-and-JQuery-Animation-in-IE8-td4662008.html:

      To enable animation with JQuery on replacing a component with Ajax, we have followed the construct with the "|"-Symbol (pipe) in the Javascript that is added with target.prependJavaScript (see http://wicketinaction.com/2013/02/replace-components-with-animation => Thank you, Martin)

      This does not seem to work in IE8. I pass a function like this: prependJavaScript("notify|myfunction(notify, '" + container.getMarkupId() + "')");

      The Function looks like this:
      function myfunction(notify, id)

      { Wicket.Log.info("this is not reached in IE8"); JQuery("#" + id).slideUp(500, notify); }

      In IE8, myfunction is not called at all. On FF and other Browsers everything works okay.

        Activity

        Martin Grigorov added a comment -

        The problem is that String.split(Regex) doesn't work very well in IE8 and older - http://stackoverflow.com/a/8511819/497381.

        Hans Lesmeister added a comment -

        Start the Quick-Start with mvn jetty:run
        In the Browser: localhost:8182 (Note the port)
        Click in Animate: Text slides in and then out again in normal browsers.
        In IE8 Text does not slide-in. prepend-Javascript with | (pipe) is not executed.


          People

          • Assignee:
            Martin Grigorov
            Reporter:
            Hans Lesmeister
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development