Wicket
  1. Wicket
  2. WICKET-5343

AutoCompleteTextField suggestions popup position is wrong when its container has scrollbar

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.11.0, 7.0.0-M1
    • Component/s: None
    • Labels:
      None

      Description

      The position of suggestions popup is wrongly calculated if the container of the owner component has a scroll bar.

      1. autocomplete-test.zip
        29 kB
        Andrea Del Bene

        Activity

        Andrea Del Bene created issue -
        Andrea Del Bene added a comment -

        quickstart

        Andrea Del Bene made changes -
        Field Original Value New Value
        Attachment autocomplete-test.zip [ 12602067 ]
        Andrea Del Bene added a comment -

        Using getBoundingClientRect inside getPosition(obj) should fix the problem. I'm testing it.

        Martin Grigorov added a comment -

        Andrea: I saw you pushed an improvement both in 6.x and master branches. Is there anything more to be done ?

        Martin Grigorov added a comment -

        I've tested the issue on all major browsers - Chrome 29, Firefox 23, Opera 12.16, IE 9 and Safari 5.1. The issue is fixed.

        Martin Grigorov made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Andrea Del Bene [ bitstorm ]
        Fix Version/s 7.0.0 [ 12322958 ]
        Fix Version/s 6.11.0 [ 12324874 ]
        Resolution Fixed [ 1 ]
        Andrea Del Bene added a comment -

        thank you! I've forgot to ask you to close it.

        ps: can I be granted the right to close an issue?

        Martin Grigorov added a comment -

        Yes, I've added you to the Jira "Committers" role, so you should be able.

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        7d 16h 20m 1 Martin Grigorov 16/Sep/13 12:28

          People

          • Assignee:
            Andrea Del Bene
            Reporter:
            Andrea Del Bene
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development