Wicket
  1. Wicket
  2. WICKET-5310

if wicket is an external lib, BundleStringResourceLoader doesn't work

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.9.1
    • Fix Version/s: 6.10.0, 7.0.0-M1
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Apache Tomcat/7.0.39

      Description

      We have got serveral Wicket-based Wepapps on our server and in order to save space, we have move all shared libs (including wicket) into a shared folder which is included via the "common.loader" of the catalina.properties file. (Using Apache Tomcat/7.0.39)
      The Problem is now, that StringResourceModel works normal, but the BundleStringResourceLoader doesn't work anymore. It always returns null.

      How to reproduce:
      Build attached quickstart
      Remove wicket-libs from war
      Deploy in Tomcat

        Activity

        Martin Grigorov added a comment -

        Fixed.
        Now Wicket will fallback to thread's context class loader if the resource cannot be found as before.


          People

          • Assignee:
            Martin Grigorov
            Reporter:
            Paul
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development